summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Yuan2015-07-29 00:23:35 +0200
committerKai Yuan2015-07-29 00:23:35 +0200
commit375ff879bfffda84bc7f524af5c6d66ac5b312b3 (patch)
tree7d26da85bcf514f196cbb979277fc711c58fcde3
downloadaur-375ff879bfffda84bc7f524af5c6d66ac5b312b3.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
3 files changed, 59 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d36213e52ad7
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = tinyswitch
+ pkgdesc = commandline tool to switch tinyproxy based proxy conveniently
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = https://github.com/sk1418/tinyswitch
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = tinyproxy
+
+pkgname = tinyswitch
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d36213e52ad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tinyswitch
+ pkgdesc = commandline tool to switch tinyproxy based proxy conveniently
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = https://github.com/sk1418/tinyswitch
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = tinyproxy
+
+pkgname = tinyswitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26ce52f49abe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kai Yuan <kent.yuan @t gmail d@t com>
+pkgname=tinyswitch
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="commandline tool to switch tinyproxy based proxy conveniently"
+arch=('any')
+url="https://github.com/sk1418/tinyswitch"
+license=('GPL3')
+depends=('python2' 'tinyproxy')
+#source=("https://github.com/sk1418/${pkgname}/archive/${pkgver}.tar.gz")
+#source=("https://tinyswitch.googlecode.com/files/${pkgname}_${pkgver}.tar.gz")
+
+_gitroot="https://github.com/sk1418/tinyswitch.git"
+_gitname="tinyswitch"
+package() {
+ cd ${srcdir}/
+ msg "Connecting to the GIT server...."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot}
+ fi
+ cd "${srcdir}/${_gitname}"
+ git checkout master
+ msg "GIT checkout done."
+
+ cd "$srcdir/${pkgname}"
+ find . -name "*.py" |xargs sed -i "s|/usr/bin/python|&2|"
+
+ python2 setup.py install --root="$pkgdir" --prefix="/usr" || return 1
+}
+
+# vim:set ts=2 sw=2 et: