summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFoppe Hemminga2015-07-07 13:57:36 +0200
committerFoppe Hemminga2015-07-07 13:57:36 +0200
commit1e14fbb50fdbfed5bf05c408c984fee77d4a4008 (patch)
treed5d2d6409caf7eed2864c72ba224a4b73d7240a5
downloadaur-1e14fbb50fdbfed5bf05c408c984fee77d4a4008.tar.gz
Initial commit copy of AUR3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--tinyuml.sh2
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76ab9f7bc760
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tinyuml
+ pkgdesc = A tool for creation of UML 2 diagrams with a focus on easy use and a small & stable feature set
+ pkgver = 0.13_02
+ pkgrel = 4
+ url = https://tinyuml.wordpress.com/about/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = java-runtime
+ source = http://sourceforge.net/projects/tinyuml/files/tinyuml/0.13/tinyuml-0.13_02-bin.zip
+ source = tinyuml.sh
+ md5sums = 0050ecb62f2563cb3e1f5932cf762a9c
+ md5sums = c308aec89648dc15da0b710671127927
+
+pkgname = tinyuml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfef38ed88e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Foppe HEMMINGA <foppe(at)foppe(dot)org>
+# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
+pkgname=tinyuml
+pkgver=0.13_02
+pkgrel=4
+pkgdesc="A tool for creation of UML 2 diagrams with a focus on easy use and a small & stable feature set"
+arch=('i686' 'x86_64')
+url="https://tinyuml.wordpress.com/about/"
+license=('GPL')
+depends=('java-runtime')
+makedepends=('unzip')
+source=("http://sourceforge.net/projects/tinyuml/files/tinyuml/0.13/tinyuml-0.13_02-bin.zip"
+ "${pkgname}.sh")
+md5sums=('0050ecb62f2563cb3e1f5932cf762a9c'
+ 'c308aec89648dc15da0b710671127927')
+
+package(){
+ cd "$srcdir"/$pkgname-$pkgver-bin/
+ install -d -m755 "$pkgdir"/usr/share/java/$pkgname/lib
+ install -m644 lib/*.jar "$pkgdir"/usr/share/java/$pkgname/lib/
+ install -m644 $pkgname.jar "$pkgdir"/usr/share/java/$pkgname/
+ install -D -m755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/tinyuml.sh b/tinyuml.sh
new file mode 100644
index 000000000000..9d299d9458b5
--- /dev/null
+++ b/tinyuml.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar "/usr/share/java/tinyuml/tinyuml.jar" "$@"