summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMicrochipQ2021-11-03 05:41:30 +0200
committerMicrochipQ2021-11-03 05:41:30 +0200
commita02facb60d39d60d084afd1e4f4996c2288f2b0f (patch)
tree2927b02ac2fe3a6699cb8d95141d28a8d9bf9a1c
downloadaur-a02facb60d39d60d084afd1e4f4996c2288f2b0f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5dc8de9fa33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tinywl-git
+ pkgdesc = TinyWL
+ pkgver = 0.14.0.r335.ge13f3f86
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/wlroots/wlroots
+ arch = x86_64
+ license = custom:MIT
+ makedepends = git
+ makedepends = make
+ makedepends = wayland-protocols
+ depends = wlroots
+ provides = tinywl=0.14.0
+ conflicts = tinywl
+ source = tinywl-git::git+https://gitlab.freedesktop.org/wlroots/wlroots
+ sha512sums = SKIP
+
+pkgname = tinywl-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90f824898b02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: MicrochipQ <microchipq@gmail.com>
+
+pkgname=tinywl-git
+pkgver=0.14.0.r335.ge13f3f86
+pkgrel=1
+license=(custom:MIT)
+pkgdesc='TinyWL'
+url=https://gitlab.freedesktop.org/wlroots/wlroots
+arch=(x86_64)
+provides=("tinywl=${pkgver%%.r*}")
+conflicts=(tinywl)
+depends=(wlroots)
+makedepends=(git make wayland-protocols)
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd $srcdir/$pkgname/tinywl
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname/tinywl
+ install -Dm755 tinywl $pkgdir/usr/bin/tinywl
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}