summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-12-20 10:57:28 +0800
committerDario Giovannetti2015-12-20 10:57:28 +0800
commit556ad1c04650b685d9dfe3c11876738057a4bb19 (patch)
tree9a689804d9554b8d2666458355f48569f01cd2f5
downloadaur-556ad1c04650b685d9dfe3c11876738057a4bb19.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--add_install_taget.patch23
-rw-r--r--fix_ftbfs_ld_as_needed.patch17
-rw-r--r--tinywm.desktop11
5 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7610d07d761f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Dec 20 02:56:56 UTC 2015
+pkgbase = tinywm
+ pkgdesc = A tiny window manager written in only ~50 lines of code
+ pkgver = 1.3
+ pkgrel = 9
+ url = http://incise.org/tinywm.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libx11
+ depends = python2-xlib
+ source = http://incise.org/files/dev/tinywm-1.3.tgz
+ source = add_install_taget.patch
+ source = fix_ftbfs_ld_as_needed.patch
+ source = tinywm.desktop
+ md5sums = 8b1c1c3a0615af122b6f9f16ead6a34e
+ md5sums = 5e27fe3b6fdde27b52805bd65febdff9
+ md5sums = 90d4babe618fced0591edc2fe36eb123
+ md5sums = 1c8c4ff10c7c9af52e0c6d1eb14cf523
+
+pkgname = tinywm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f92fd8f82ef6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Andrew Antle <andrew dot antle at gmail dot com>
+# Contributor: Tim Yang <tdy@gmx.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Mateusz Lukasik <mati75@linuxmint.pl>
+
+pkgname=tinywm
+pkgver=1.3
+pkgrel=9
+pkgdesc="A tiny window manager written in only ~50 lines of code"
+arch=('i686' 'x86_64')
+url="http://incise.org/tinywm.html"
+license=('custom')
+depends=('libx11' 'python2-xlib')
+source=(http://incise.org/files/dev/$pkgname-$pkgver.tgz
+'add_install_taget.patch'
+'fix_ftbfs_ld_as_needed.patch'
+'tinywm.desktop')
+md5sums=('8b1c1c3a0615af122b6f9f16ead6a34e'
+'5e27fe3b6fdde27b52805bd65febdff9'
+'90d4babe618fced0591edc2fe36eb123'
+'1c8c4ff10c7c9af52e0c6d1eb14cf523')
+
+build() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/add_install_taget.patch"
+ patch -Np1 -i "$srcdir/fix_ftbfs_ld_as_needed.patch"
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -D -m755 $pkgname $pkgdir/usr/bin/$pkgname
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -D -m755 $pkgname.py $pkgdir/usr/bin/$pkgname.py
+ install -D -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/xsessions/$pkgname.desktop
+}
diff --git a/add_install_taget.patch b/add_install_taget.patch
new file mode 100644
index 000000000000..a9b55eb44762
--- /dev/null
+++ b/add_install_taget.patch
@@ -0,0 +1,23 @@
+Description: Add install target to Makefile
+Forwarded: no
+Origin: no
+Bug-Debian: no
+Author: Nobuhiro Iwamatsu <iwamatsu@debian.org>
+
+--- tinywm-1.3.orig/Makefile
++++ tinywm-1.3/Makefile
+@@ -1,9 +1,14 @@
++BINDIR?=/usr/bin
+ PREFIX?=/usr/X11R6
+ CFLAGS?=-Os -pedantic -Wall
+
+ all:
+ $(CC) $(CFLAGS) -I$(PREFIX)/include -L$(PREFIX)/lib -lX11 -o tinywm tinywm.c
+
++install:
++ install -d ${DESTDIR}${BINDIR}
++ install -m 755 tinywm ${DESTDIR}${BINDIR}
++
+ clean:
+ rm -f tinywm
+
diff --git a/fix_ftbfs_ld_as_needed.patch b/fix_ftbfs_ld_as_needed.patch
new file mode 100644
index 000000000000..f36c68cdadf0
--- /dev/null
+++ b/fix_ftbfs_ld_as_needed.patch
@@ -0,0 +1,17 @@
+Description: Fix ftbfs with ld --as-needed
+Forwarded: no
+Origin: no
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641397
+Author: Matthias Klose <doko@ubuntu.com>
+
+--- a/Makefile 2011-09-27 12:22:03.000000000 +0900
++++ b/Makefile 2011-09-27 12:22:13.000000000 +0900
+@@ -3,7 +3,7 @@
+ CFLAGS?=-Os -pedantic -Wall
+
+ all:
+- $(CC) $(CFLAGS) -I$(PREFIX)/include -L$(PREFIX)/lib -lX11 -o tinywm tinywm.c
++ $(CC) $(CFLAGS) -I$(PREFIX)/include tinywm.c -L$(PREFIX)/lib -lX11 -o tinywm
+
+ install:
+ install -d ${DESTDIR}${BINDIR}
diff --git a/tinywm.desktop b/tinywm.desktop
new file mode 100644
index 000000000000..5b6d189504b0
--- /dev/null
+++ b/tinywm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Tinywm
+Comment=Ridiculously tiny window manager
+Exec=tinywm
+Terminal=False
+TryExec=tinywm
+Type=Application
+
+[Window Manager]
+SessionManaged=true