summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-12-20 11:04:59 +0800
committerDario Giovannetti2015-12-20 11:04:59 +0800
commit219ae1c138af43a48ee673b3fa6136eeea3b2dc3 (patch)
tree82137442b48740c83807141a6bdc113d144a6d1d
downloadaur-219ae1c138af43a48ee673b3fa6136eeea3b2dc3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c701839dfc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Dec 20 03:04:42 UTC 2015
+pkgbase = tinywm-git
+ pkgdesc = A tiny window manager written in only ~50 lines of code
+ pkgver = 20121222
+ pkgrel = 1
+ url = http://incise.org/tinywm.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = libx11
+ optdepends = python-xlib: for python version (uncomment last line of PKGBUILD)
+ provides = tinywm
+ conflicts = tinywm
+
+pkgname = tinywm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cdce8c89af9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Mateusz Łukasik <mati75@linuxmint.pl>
+
+pkgname=tinywm-git
+pkgver=20121222
+pkgrel=1
+pkgdesc="A tiny window manager written in only ~50 lines of code"
+arch=('i686' 'x86_64')
+url="http://incise.org/tinywm.html"
+license=('custom')
+makedepends=('git')
+provides=('tinywm')
+conflicts=('tinywm')
+depends=('libx11')
+optdepends=('python-xlib: for python version (uncomment last line of
+PKGBUILD)')
+
+_gitroot="git://github.com/mackstann/tinywm.git"
+_gitname="tinywm"
+
+build() {
+ msg "Avahi needs to be running to run tests."
+ msg "Remove the 'make test' line in the PKGBUILD if you don't want to
+run tests."
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -D -m755 tinywm $pkgdir/usr/bin/tinywm
+ install -D -m644 README $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ #install -D -m755 tinywm.py $pkgdir/usr/bin/tinywm.py
+}