summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Østergaard2022-02-15 18:42:35 +0100
committerNick Østergaard2022-02-15 18:44:05 +0100
commitbdc786660008e5ff48b80ddb3d1ef6f27fac186a (patch)
treee1f9c316ce6f528294aa42e4e5ca87f9e0e16e4b
parent702bc26e46c1aff53e82992d9b421dbd7c8b75a7 (diff)
downloadaur-bdc786660008e5ff48b80ddb3d1ef6f27fac186a.tar.gz
Bump to 1.34 and use the build system meson
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49b4a0a874d7..e6b7156ac0e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = tio
pkgdesc = The simple TTY terminal I/O application
- pkgver = 1.32
+ pkgver = 1.34
pkgrel = 1
url = http://tio.github.io/
arch = x86_64
arch = i686
license = GPLv2
- source = https://github.com/tio/tio/releases/download/v1.32/tio-1.32.tar.xz
- sha256sums = a8f5ed6994cacb96780baa416b19e5a6d7d67e8c162a8ea4fd9eccd64984ae44
+ makedepends = meson
+ depends = glibc
+ source = https://github.com/tio/tio/releases/download/v1.34/tio-1.34.tar.xz
+ sha256sums = ec5f659fcab6ebab5ff3aa8737d67809441e6f69f62fc8f38ab11986908254e1
pkgname = tio
-
diff --git a/PKGBUILD b/PKGBUILD
index 3eeffeae85db..859a432b005d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Martin Hundebøll <martin@hundeboll.net>
pkgname=tio
-pkgver=1.32
+pkgver=1.34
pkgrel=1
pkgdesc="The simple TTY terminal I/O application"
url="http://tio.github.io/"
arch=('x86_64' 'i686')
license=('GPLv2')
+depends=('glibc')
+makedepends=('meson')
source=("https://github.com/tio/tio/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('a8f5ed6994cacb96780baa416b19e5a6d7d67e8c162a8ea4fd9eccd64984ae44')
+sha256sums=('ec5f659fcab6ebab5ff3aa8737d67809441e6f69f62fc8f38ab11986908254e1')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ meson --prefix=/usr --buildtype=plain . build
+ meson compile -C build
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ meson install -C build --destdir "$pkgdir"
}
# vim:set ts=2 sw=2 et: