summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanwo2018-06-05 18:50:37 +0800
committerXuanwo2018-06-05 18:50:37 +0800
commitb33bae208f7b86302e7ac547e030537e188d2fef (patch)
tree2d490dbd9c36e7f3e1dd0fa28ddf2970ba67a57d
downloadaur-b33bae208f7b86302e7ac547e030537e188d2fef.tar.gz
Initial commit
Signed-off-by: Xuanwo <xuanwo.cn@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fad79a9969b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tiresias-bin
+ pkgdesc = A tool to help you access your servers.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/Xuanwo/tiresias
+ arch = x86_64
+ license = Apache
+ provides = tiresias
+ source = https://github.com/Xuanwo/tiresias/releases/download/v0.0.1/tiresias_v0.0.1_linux_amd64.tar.gz
+ sha256sums = 0348a7b696c3b9a21f6b2323453b17928609e3b6e73b31c112c63cdeeeef405e
+
+pkgname = tiresias-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43d45ba55bf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Xuanwo <xuanwo.cn#gmail.com>
+
+pkgname=tiresias-bin
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A tool to help you access your servers."
+arch=("x86_64")
+url="https://github.com/Xuanwo/tiresias"
+license=("Apache")
+provides=("tiresias")
+source=("https://github.com/Xuanwo/tiresias/releases/download/v${pkgver}/tiresias_v${pkgver}_linux_amd64.tar.gz")
+sha256sums=("0348a7b696c3b9a21f6b2323453b17928609e3b6e73b31c112c63cdeeeef405e")
+
+
+package() {
+ # binary
+ install -Dm0755 tiresias_v${pkgver}_linux_amd64 "${pkgdir}/usr/bin/tiresias"
+}