summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-05-10 23:04:47 +0200
committerPieter Goetschalckx2016-05-10 23:04:47 +0200
commitac5950c7d36a6890bf4a4fbfc741eadd4580a7d8 (patch)
treecf39cb466d9f1081574f7760f3a3ea64d867a2d1
downloadaur-ac5950c7d36a6890bf4a4fbfc741eadd4580a7d8.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1894f528d324
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tis-interpreter-git
+ pkgdesc = An interpreter for finding subtle bugs in programs written in standard C
+ pkgver = r47.e8de317
+ pkgrel = 1
+ url = https://github.com/TrustInSoft/tis-interpreter
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = ocaml
+ depends = ocaml-findlib
+ depends = zarith
+ depends = ocaml-easy-format
+ depends = ocaml-biniou
+ depends = ocaml-yojson
+ provides = tis-interpreter
+ conflicts = tis-interpreter
+ source = git+https://github.com/TrustInSoft/tis-interpreter
+ sha256sums = SKIP
+
+pkgname = tis-interpreter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fb202911ccb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+_pkgname=tis-interpreter
+pkgname=$_pkgname-git
+pkgver=r47.e8de317
+pkgrel=1
+pkgdesc="An interpreter for finding subtle bugs in programs written in standard C"
+arch=('i686' 'x86_64')
+url="https://github.com/TrustInSoft/tis-interpreter"
+license=('LGPL2.1')
+depends=('ocaml' 'ocaml-findlib' 'zarith' 'ocaml-easy-format' 'ocaml-biniou' 'ocaml-yojson')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/TrustInSoft/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ sed -i 's#^ROOT_PATH=.*$#ROOT_PATH=/usr/share/tis-interpreter#' "tis-interpreter/tis-interpreter.sh"
+ sed -i 's#^TIS_PATH=.*$#TIS_PATH=/usr#' "tis-interpreter/tis-interpreter.sh"
+}
+
+build() {
+ cd "$_pkgname"
+ ./configure --prefix=/usr --disable-from_analysis --disable-gui --disable-impact --disable-inout --disable-metrics --disable-occurrence --disable-pdg --disable-postdominators --enable-rtegen --disable-scope --disable-slicing --disable-sparecode --enable-users --disable-aorai --disable-obfuscator --disable-report --disable-security_slicing --disable-wp --disable-wp-coq --disable-wp-why3 --disable-print_api --with-all-static
+ make depend
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+
+ cp -r -a "$_pkgname" "$pkgdir/usr/share/"
+ ln -s "/usr/share/tis-interpreter/tis-interpreter.sh" "$pkgdir/usr/bin/tis-interpreter"
+}