summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol2022-03-28 21:10:50 +0200
committerPau Espin Pedrol2022-03-28 21:10:54 +0200
commit0c1891ce850b8412ec8e49b36aceefb11f06e422 (patch)
treedeb74b1b23c86e5b5d9e06a046f3a376a7746459
parentf60d6bf50e97e7afb92316bbd908094c4e26569e (diff)
downloadaur-0c1891ce850b8412ec8e49b36aceefb11f06e422.tar.gz
Generate pkgver as specified in the wiki
As per https://wiki.archlinux.org/title/VCS_package_guidelines#Git
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22db2c2ed365..8db94329296b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=titan-git
_pkgname=titan.core
pkgver=8.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="TTCN3 test automation platform"
arch=('i686' 'x86_64')
url="https://projects.eclipse.org/projects/tools.titan"
@@ -16,8 +16,8 @@ md5sums=('SKIP'
'ecccd5d48359f5f0bdd81c8cc036e806')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/./g'
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {