summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2023-08-30 01:06:26 +0700
committerVadim Yanitskiy2023-08-30 01:21:27 +0700
commitde76f280611acecbe8a61b552ca5933702c1b6c6 (patch)
tree6329c4d3f4f0a2361bd3ff71549d74a3ef90590a
parentc41564f25a9d337d1ff51f70d8d737dc027e0f00 (diff)
downloadaur-de76f280611acecbe8a61b552ca5933702c1b6c6.tar.gz
Fix build: make dep, disable lto/buildflags/makeflags
Currently we cannot build even old versions due to broken dependencies in the TITAN's hand-written Makefiles. Making the 'dep' target first helps to overcome the majority of them, but it still does not compile due to various compilation errors. Disabling 'lto' was recommended by the project maintainers [1]. I also had to disable '{build,make}flags' to overcome the compilation errors and make-loops (endlessly making the same subdir). [1] https://gitlab.eclipse.org/eclipse/titan/titan.core/-/issues/595
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5058ce36f06f..3f4184074dab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,9 @@ pkgbase = titan-git
depends = ncurses
depends = openssl
depends = jdk8-openjdk
+ options = !lto
+ options = !buildflags
+ options = !makeflags
source = git+https://gitlab.eclipse.org/eclipse/titan/titan.core.git
source = titan.profile
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a93aaa9d2aed..77091f0cb15e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,23 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+# Currently we cannot build even old versions due to broken dependencies in
+# the TITAN's hand-written Makefiles. Building the 'dep' target first helps
+# to overcome the majority of them, but it still does not compile due to
+# various compilation errors. Disabling 'buildflags' and 'makeflags' helps.
+# See also https://gitlab.eclipse.org/eclipse/titan/titan.core/-/issues/595.
+options=(!lto !buildflags !makeflags)
+
+prepare() {
+ cd $srcdir/$_pkgname
+ echo "TTCN3_DIR := /usr/ttcn3" >> Makefile.personal
+ echo "JDKDIR := /usr/lib/jvm/java-8-openjdk" >> Makefile.personal
+}
+
build() {
cd $srcdir/$_pkgname
- make \
- TTCN3_DIR=/usr/ttcn3 \
- JDKDIR=/usr/lib/jvm/java-8-openjdk
+ make dep
+ make
}
package() {