summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 18:04:33 +0100
committerBartłomiej Piotrowski2018-01-05 18:04:33 +0100
commitf24e18c1fa4c0ab36a3ab11267fac09939ef9479 (patch)
tree61197fb0a4551f725d2925d95caf0d7c60f5397f
downloadaur-f24e18c1fa4c0ab36a3ab11267fac09939ef9479.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD62
-rw-r--r--tcl-tk-path.patch22
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf5e51f4ac8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tix
+ pkgdesc = Tk Interface eXtension, a powerful set of user interface components
+ pkgver = 8.4.3
+ pkgrel = 5
+ url = http://tix.sourceforge.net/
+ arch = x86_64
+ license = BSD
+ depends = tk
+ depends = libx11
+ source = http://downloads.sourceforge.net/tix/Tix8.4.3-src.tar.gz
+ source = tix-8.4.3-tcl8.6.patch::https://bugs.archlinux.org/task/36882?getfile=10973
+ source = tcl-tk-path.patch
+ md5sums = 2b8bf4b10a852264678182652f477e59
+ md5sums = c26297f9e1744dc38308a062ef00549e
+ md5sums = d4df48da39dd51872d58706a51bab505
+
+pkgname = tix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7ce5f693e80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
+
+pkgname=tix
+pkgver=8.4.3
+pkgrel=5
+pkgdesc="Tk Interface eXtension, a powerful set of user interface components"
+arch=('x86_64')
+url="http://tix.sourceforge.net/"
+license=("BSD")
+depends=('tk' 'libx11')
+source=("http://downloads.sourceforge.net/tix/Tix$pkgver-src.tar.gz"
+ "tix-8.4.3-tcl8.6.patch::https://bugs.archlinux.org/task/36882?getfile=10973"
+ "tcl-tk-path.patch")
+md5sums=('2b8bf4b10a852264678182652f477e59'
+ 'c26297f9e1744dc38308a062ef00549e'
+ 'd4df48da39dd51872d58706a51bab505')
+
+prepare() {
+ cd "$srcdir"/Tix$pkgver
+ sed -i -e 's:-Os::g' -i configure tclconfig/tcl.m4
+ patch -Np1 -i "${srcdir}/tix-8.4.3-tcl8.6.patch"
+ sed -i -e 's:generic/tclInt.h:tclInt.h:g' configure
+ sed -i -e 's:generic/tkInt.h:tkInt.h:g' configure
+}
+
+build() {
+ cd "$srcdir"/Tix$pkgver
+
+ export CFLAGS="$CFLAGS -DERR_IN_PROGRESS=2"
+ [[ $CARCH == "x86_64" ]] && BIT="--enable-64bit"
+
+ ./configure --prefix=/usr \
+ --with-tcl=/usr/lib \
+ --with-tk=/usr/lib \
+ $BIT \
+
+ make
+}
+
+package() {
+ cd "$srcdir"/Tix$pkgver
+ make DESTDIR="$pkgdir" install
+ # move things around
+
+ install -m755 tools/tixindex "$pkgdir"/usr/bin/tixindex
+ rm -rf "$pkgdir"/usr/lib/Tix8.4/html
+ rm -f "$pkgdir"/usr/lib/Tix8.4/{README.txt,license.terms}
+ ln -s Tix$pkgver/libTix$pkgver.so "$pkgdir"/usr/lib/libTix$pkgver.so
+
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ mkdir -p "$pkgdir"/usr/share/man/man3
+ cp -p man/tixwish.1 "$pkgdir"/usr/share/man/man1
+ cd "$srcdir"/Tix$pkgver/man
+ for i in *.n; do
+ cp -p $i "$pkgdir"/usr/share/man/man3/${i%n}3
+ done
+
+ mkdir -p "$pkgdir"/usr/share/licenses/tix
+ cp "$srcdir"/Tix$pkgver/license.terms "$pkgdir"/usr/share/licenses/tix/
+}
diff --git a/tcl-tk-path.patch b/tcl-tk-path.patch
new file mode 100644
index 000000000000..2fc12671ed48
--- /dev/null
+++ b/tcl-tk-path.patch
@@ -0,0 +1,22 @@
+diff -wbBur Tix8.4.3/configure Tix8.4.3.my/configure
+--- Tix8.4.3/configure 2008-02-28 04:35:01.000000000 +0000
++++ Tix8.4.3.my/configure 2009-12-28 10:57:33.000000000 +0000
+@@ -6645,7 +6645,7 @@
+ ;;
+ esac
+ else
+- if test ! -f "${TCL_SRC_DIR}/generic/tclInt.h" ; then
++ if test ! -f "${TCL_SRC_DIR}/tclInt.h" ; then
+ { { echo "$as_me:$LINENO: error: Cannot find private header tclInt.h in ${TCL_SRC_DIR}" >&5
+ echo "$as_me: error: Cannot find private header tclInt.h in ${TCL_SRC_DIR}" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -6700,7 +6700,7 @@
+ ;;
+ esac
+ else
+- if test ! -f "${TK_SRC_DIR}/generic/tkInt.h" ; then
++ if test ! -f "${TK_SRC_DIR}/tk-private/generic/tkInt.h" ; then
+ { { echo "$as_me:$LINENO: error: Cannot find private header tkInt.h in ${TK_SRC_DIR}" >&5
+ echo "$as_me: error: Cannot find private header tkInt.h in ${TK_SRC_DIR}" >&2;}
+ { (exit 1); exit 1; }; }
+