summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan A. Rubio2020-05-24 13:44:49 +0100
committerJuan A. Rubio2020-05-24 13:44:49 +0100
commit7c20fe0320b9ae397f7fc114402c735f05223093 (patch)
tree2f63b23c0a59ed928c319c326df86e97d57b45de
parent8cc9fdd6db52913ba0bbc720ea2b2bec134b7f37 (diff)
downloadaur-tizonia-all.tar.gz
tizonia-all: updated to track 0.22.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD13
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b8a778b3321..22f760635965 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = tizonia-all
- pkgdesc = Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, TuneIn, Plex servers and Chromecast devices.
- pkgver = 0.21.0
- pkgrel = 2
+ pkgdesc = Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, TuneIn, iHeartRadio, Plex servers and Chromecast devices.
+ pkgver = 0.22.0
+ pkgrel = 1
url = https://tizonia.org
arch = x86_64
license = LGPL
+ makedepends = git
+ makedepends = boost
+ makedepends = meson
+ makedepends = ninja
depends = libmad
depends = sqlite
depends = libutil-linux
@@ -26,8 +30,8 @@ pkgbase = tizonia-all
depends = libsndfile
depends = alsa-lib
depends = libpulse
- depends = boost
- depends = check
+ depends = boost-libs
+ depends = hicolor-icon-theme
depends = python-pafy
depends = python-eventlet
depends = youtube-dl
@@ -41,8 +45,8 @@ pkgbase = tizonia-all
depends = python-plexapi
depends = python-fuzzywuzzy
depends = python-spotipy
- source = tizonia-openmax-il-0.21.0.tar.gz::https://github.com/tizonia/tizonia-openmax-il/archive/v0.21.0.tar.gz
- md5sums = 5380afc416a16e14aa76f6845259813b
+ source = tizonia-openmax-il-0.22.0.tar.gz::https://github.com/tizonia/tizonia-openmax-il/archive/v0.22.0.tar.gz
+ md5sums = 236dd33a25700bf8d752af17b95bd50f
pkgname = tizonia-all
diff --git a/PKGBUILD b/PKGBUILD
index 938bed8f48b2..0c1ac4a99b6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
_githubname=tizonia-openmax-il
pkgname=tizonia-all
-pkgver=0.21.0
-pkgrel=2
-pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, TuneIn, Plex servers and Chromecast devices."
+pkgver=0.22.0
+pkgrel=1
+pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, TuneIn, iHeartRadio, Plex servers and Chromecast devices."
arch=('x86_64')
url="https://tizonia.org"
license=('LGPL')
+makedepends=(git boost meson ninja)
depends=(
# official repositories:
'libmad'
@@ -31,8 +32,8 @@ depends=(
'libsndfile'
'alsa-lib'
'libpulse'
- 'boost'
- 'check'
+ 'boost-libs'
+ 'hicolor-icon-theme'
'python-pafy'
'python-eventlet'
'youtube-dl'
@@ -50,7 +51,7 @@ depends=(
'python-spotipy'
)
source=("${_githubname}-${pkgver}.tar.gz"::"https://github.com/tizonia/${_githubname}/archive/v${pkgver}.tar.gz")
-md5sums=('5380afc416a16e14aa76f6845259813b')
+md5sums=('236dd33a25700bf8d752af17b95bd50f')
prepare() {
command -v tizonia &> /dev/null \