summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan A. Rubio2017-08-26 23:14:22 +0100
committerJuan A. Rubio2017-08-26 23:14:22 +0100
commit8802093e094eb1c5645c4b017dfb1ea8d5ac2b77 (patch)
treed218334ec0675f94d9ea91537f6f693654162b79
downloadaur-8802093e094eb1c5645c4b017dfb1ea8d5ac2b77.tar.gz
tizonia-all: first aur release (0.9.0)
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD75
2 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4950919d02d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = tizonia-all
+ pkgdesc = Command-line cloud music player for Linux with Spotify, Google Play Music, YouTube, SoundCloud, and Dirble support
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://www.tizonia.org
+ arch = x86_64
+ license = LGPL
+ depends = libmad
+ depends = sqlite
+ depends = libutil-linux
+ depends = taglib
+ depends = mediainfo
+ depends = sdl
+ depends = lame
+ depends = faad2
+ depends = libcurl-gnutls
+ depends = libvorbis
+ depends = libvpx
+ depends = mpg123
+ depends = opus
+ depends = opusfile
+ depends = libogg
+ depends = libfishsound
+ depends = flac
+ depends = liboggz
+ depends = libsndfile
+ depends = alsa-lib
+ depends = libpulse
+ depends = boost
+ depends = dbus-c++
+ depends = check
+ depends = python2-pafy
+ depends = log4c
+ depends = libspotify
+ depends = python2-gmusicapi
+ depends = python-soundcloud-git
+ depends = python2-youtube-dl-git
+ source = tizonia-openmax-il-0.9.0.tar.gz::https://github.com/tizonia/tizonia-openmax-il/archive/v0.9.0.tar.gz
+ md5sums = d6775a42f04c2808b9274827bf6b5879
+
+pkgname = tizonia-all
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b75e701e1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Juan A. Rubio <jarubio2001@gmail.com>
+
+_githubname=tizonia-openmax-il
+pkgname=tizonia-all
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Command-line cloud music player for Linux with Spotify, Google Play Music, YouTube, SoundCloud, and Dirble support"
+arch=('x86_64')
+url="https://www.tizonia.org"
+license=('LGPL')
+depends=(
+ # official repositories:
+ 'libmad'
+ 'sqlite'
+ 'libutil-linux'
+ 'taglib'
+ 'mediainfo'
+ 'sdl'
+ 'lame'
+ 'faad2'
+ 'libcurl-gnutls'
+ 'libvorbis'
+ 'libvpx'
+ 'mpg123'
+ 'opus'
+ 'opusfile'
+ 'libogg'
+ 'libfishsound'
+ 'flac'
+ 'liboggz'
+ 'libsndfile'
+ 'alsa-lib'
+ 'libpulse'
+ 'boost'
+ 'dbus-c++'
+ 'check'
+ 'python2-pafy'
+
+ # AUR:
+ 'log4c'
+ 'libspotify'
+ 'python2-gmusicapi'
+ 'python-soundcloud-git'
+ 'python2-youtube-dl-git'
+)
+source=("${_githubname}-${pkgver}.tar.gz"::"https://github.com/tizonia/${_githubname}/archive/v${pkgver}.tar.gz")
+md5sums=('d6775a42f04c2808b9274827bf6b5879')
+
+prepare() {
+ mkdir -p "$srcdir/path"
+ # Tizonia expects Python 2
+ ln -sf /usr/bin/python2 "$srcdir/path/python"
+ ln -sf /usr/bin/python2-config "$srcdir/path/python-config"
+}
+
+build() {
+ export PATH="$srcdir/path:$PATH"
+ export PYTHON="/usr/bin/python2"
+ cd "${_githubname}-${pkgver}"
+ autoreconf -ifs
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --silent \
+ --enable-silent-rules \
+ CFLAGS='-O2 -s -DNDEBUG' \
+ CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security'
+ make
+}
+
+package() {
+ cd "${_githubname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+}