summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-01-30 14:49:40 +0100
committergit user2024-01-30 14:49:40 +0100
commit5305607e8ee12702e4d1c47cfc844f33cbf4c6b4 (patch)
treee5b2a374c0e4b1584fd0715b4f03797cdb929c99
parent2bc0a2ada85c9637fbaca172168244c4c56c4f81 (diff)
downloadaur-5305607e8ee12702e4d1c47cfc844f33cbf4c6b4.tar.gz
Use `taglib1`, since this software is not compatible with `taglib>=2`.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--use-taglib1.patch14
3 files changed, 30 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db437e23dbd9..c2386f1ea0d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tizonia-all-git
pkgdesc = Command-line cloud music player and downloader for Linux with support for YouTube, SoundCloud, Plex servers, Chromecast devices and generic streams and websites.
pkgver = 0.22.0+28.r3903.20210110.a1e8f8bd
- pkgrel = 6
+ pkgrel = 7
url = https://www.tizonia.org
arch = x86_64
license = LGPL-3.0-or-later
@@ -25,16 +25,16 @@ pkgbase = tizonia-all-git
depends = liboggz
depends = libpulse
depends = libvpx
- depends = mediainfo
+ depends = mediainfo>=0.7.65
depends = mpg123
depends = opusfile
depends = python-eventlet
depends = python-joblib
depends = python-levenshtein
- depends = python>=3
+ depends = python>=3.5
depends = sdl
depends = sqlite
- depends = taglib
+ depends = taglib1>=1.7.0
depends = youtube-dl
depends = log4c
depends = python-fuzzywuzzy
@@ -55,7 +55,9 @@ pkgbase = tizonia-all-git
options = ccache
source = tizonia::git+https://github.com/tizonia/tizonia-openmax-il.git
source = fix_chromecast_placeholders_error.patch::https://github.com/tizonia/tizonia-openmax-il/files/9795320/fix_chromecast_placeholders_error.patch.txt
+ source = use-taglib1.patch
sha256sums = SKIP
sha256sums = 8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea
+ sha256sums = 6388dadcef0273b315ae60cb1d8631021ee701082f3624fa62c3c9db357f79b5
pkgname = tizonia-all-git
diff --git a/PKGBUILD b/PKGBUILD
index 42e51c491ad9..e53f43cbd010 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname='tizonia'
_githubname="${_pkgname}-openmax-il"
pkgname="${_pkgname}-all-git"
pkgver=0.22.0+28.r3903.20210110.a1e8f8bd
-pkgrel=6
+pkgrel=7
pkgdesc="Command-line cloud music player and downloader for Linux with support for YouTube, SoundCloud, Plex servers, Chromecast devices and generic streams and websites."
arch=(
'x86_64'
@@ -24,16 +24,16 @@ depends=(
'liboggz'
'libpulse'
'libvpx'
- 'mediainfo'
+ 'mediainfo>=0.7.65'
'mpg123'
'opusfile'
'python-eventlet'
'python-joblib' # Needed by 'usr/lib/python3.11/site-packages/tizyoutubeproxy.py', 'usr/lib/python3.11/site-packages/tiziheartproxy.py', 'usr/lib/python3.11/site-packages/tiztuneinproxy.py'.
'python-levenshtein'
- 'python>=3'
+ 'python>=3.5'
'sdl'
'sqlite'
- 'taglib'
+ 'taglib1>=1.7.0'
'youtube-dl'
# AUR:
@@ -82,10 +82,12 @@ options=()
source=(
"${_pkgname}"::git+https://github.com/tizonia/${_githubname}.git
"fix_chromecast_placeholders_error.patch::https://github.com/tizonia/tizonia-openmax-il/files/9795320/fix_chromecast_placeholders_error.patch.txt"
+ "use-taglib1.patch"
)
sha256sums=(
- 'SKIP'
- '8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea'
+ 'SKIP' # Main upstream source
+ '8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea' # fix_chromecast_placeholders_error.patch
+ '6388dadcef0273b315ae60cb1d8631021ee701082f3624fa62c3c9db357f79b5' # use-taglib1.patch
)
if which ccache > /dev/null 2>&1; then
makedepends+=('ccache')
@@ -166,7 +168,8 @@ build() {
# * [2023-06-24] libspotify does no longer exist & also does no longer work, so disable it (`libspotify` would be the needed dependency), see https://aur.archlinux.org/packages/tizonia-all-git#comment-921052.
# * [2023-07-31] Google Music service is dead, but `python-gmusicapi` is still needed by `/usr/lib/python3.11/site-packages/tizgmusicproxy.py`, see https://aur.archlinux.org/packages/tizonia-all-git#comment-927188 and follow up.
# * [2023-08-01] Building tests fails with `clients/youtube/libtizyoutube/tests/check_tizyoutube.c:121:12: error: too few arguments to function ‘tiz_youtube_init’`, see https://github.com/tizonia/tizonia-openmax-il/issues/799.
- export SAMUFLAGS="-j1" # Eats a lot of ram.
+ export SAMUFLAGS="-j1" # Eats a lot of ram, so restrict to one build job at a time.
+ PKG_CONFIG_PATH=/usr/lib/taglib1/lib/pkgconfig # Also search for taglib1 pkgconfig file.
meson setup --prefix=/usr --buildtype=plain \
-Dplayer=true \
-Dlibspotify=false \
diff --git a/use-taglib1.patch b/use-taglib1.patch
new file mode 100644
index 000000000000..11382d887aa0
--- /dev/null
+++ b/use-taglib1.patch
@@ -0,0 +1,14 @@
+diff -rU1 tizonia.orig/player/configure.ac tizonia.taglib1/player/configure.ac
+--- tizonia.orig/player/configure.ac 2024-01-30 14:02:48.576436006 +0100
++++ tizonia.taglib1/player/configure.ac 2024-01-30 14:35:37.793073461 +0100
+@@ -50,2 +50,3 @@
+ PKG_CHECK_MODULES([TAGLIB], [taglib >= 1.7.0])
++PKG_CHECK_MODULES([TAGLIB], [taglib < 2])
+ PKG_CHECK_MODULES([LIBMEDIAINFO], [libmediainfo >= 0.7.65])
+diff -rU1 tizonia.orig/player/meson.build tizonia.taglib1/player/meson.build
+--- tizonia.orig/player/meson.build 2024-01-30 14:02:48.579769340 +0100
++++ tizonia.taglib1/player/meson.build 2024-01-30 14:35:39.613073435 +0100
+@@ -1,2 +1,3 @@
+ taglib_dep = dependency('taglib', required: true, version: '>=1.7.0')
++taglib_dep = dependency('taglib', required: true, version: '<2')
+ libmediainfo_dep = dependency('libmediainfo', required: true, version: '>=0.7.65')