summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-12-18 06:31:13 -0500
committerSolomon Choina2019-12-18 06:31:13 -0500
commit584307551d93f30d1f6b539971f6d0f090f4deff (patch)
tree0e0c102a88c1c9bce4d00b30689fe34e5f183f33
parentfb2ecdb764b380f6c4d746cebff983b42160bf5f (diff)
downloadaur-584307551d93f30d1f6b539971f6d0f090f4deff.tar.gz
updpkgver, moving back to master and other stuff
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD29
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2413aafa77c6..b959868b09dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tizonia-all-git
- pkgdesc = Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Dirble Internet Radio, Plex servers and Chromecast devices.
- pkgver = 0.18.0.r55.g28b2b257
+ pkgdesc = Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Plex servers and Chromecast devices.
+ pkgver = 0.19.0.r18.gc97eec7c
pkgrel = 1
url = https://www.tizonia.org
arch = x86_64
@@ -26,6 +26,7 @@ pkgbase = tizonia-all-git
depends = boost-libs
depends = hicolor-icon-theme
depends = python-eventlet
+ depends = python-levenshtein
depends = log4c
depends = libspotify
depends = python-pafy
@@ -37,7 +38,7 @@ pkgbase = tizonia-all-git
depends = python-spotipy
provides = tizonia-all
conflicts = tizonia-all
- source = tizonia-all-git::git+https://github.com/tizonia/tizonia-openmax-il.git#branch=develop
+ source = tizonia-all-git::git+https://github.com/tizonia/tizonia-openmax-il.git
sha256sums = SKIP
pkgname = tizonia-all-git
diff --git a/PKGBUILD b/PKGBUILD
index d64e584008ff..2efc5e2418dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_githubname=tizonia-openmax-il
pkgname=tizonia-all-git
-pkgver=0.18.0.r55.g28b2b257
+pkgver=0.19.0.r18.gc97eec7c
pkgrel=1
-pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Dirble Internet Radio, Plex servers and Chromecast devices."
+pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Plex servers and Chromecast devices."
arch=('x86_64')
url="https://www.tizonia.org"
license=('LGPL')
@@ -29,6 +29,7 @@ depends=(
'boost-libs'
'hicolor-icon-theme'
'python-eventlet'
+ 'python-levenshtein'
# AUR:
'log4c'
@@ -43,7 +44,8 @@ depends=(
)
provides=('tizonia-all')
conflicts=('tizonia-all')
-source=("${pkgname}"::git+https://github.com/tizonia/${_githubname}.git#branch=develop)
+options=()
+source=("${pkgname}"::git+https://github.com/tizonia/${_githubname}.git)
sha256sums=('SKIP')
pkgver() {
@@ -54,21 +56,16 @@ pkgver() {
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
-prepare() {
- command -v tizonia &> /dev/null \
- && { \
- echo >&2 "Please uninstall tizonia-all or tizonia-all-git before proceeding." ; \
- echo >&2 "See https://github.com/tizonia/tizonia-openmax-il/issues/485." ; \
- exit 1; }
- mkdir -p "$srcdir/path"
- # Tizonia expects Python 2
- ln -sf /usr/bin/python "$srcdir/path/python"
- ln -sf /usr/bin/python-config "$srcdir/path/python-config"
-}
+# prepare() {
+ #command -v tizonia &> /dev/null \
+ # && { \
+ # echo >&2 "Please uninstall tizonia-all or tizonia-all-git before proceeding." ; \
+ # echo >&2 "See https://github.com/tizonia/tizonia-openmax-il/issues/485." ; \
+ # exit 1;
+ # }
+#}
build() {
- export PATH="$srcdir/path:$PATH"
- export PYTHON="/usr/bin/python"
cd "$pkgname"
autoreconf -ifs
./configure \