summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan A. Rubio2017-08-26 23:13:24 +0100
committerJuan A. Rubio2017-08-26 23:13:24 +0100
commit7e1db1de36568adae509347009359c6ae1a431b1 (patch)
tree3c62d6fcaff41daa7abcd4094957f2a3ffbe4d7a
downloadaur-7e1db1de36568adae509347009359c6ae1a431b1.tar.gz
tizonia-all-git: first release
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD85
2 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2751bc67917
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = tizonia-all-git
+ pkgdesc = Command-line cloud music player for Linux with Spotify, Google Play Music, YouTube, SoundCloud, and Dirble support
+ pkgver = 0.9.0.r7.gee2765aa
+ pkgrel = 1
+ url = https://www.tizonia.org
+ arch = x86_64
+ license = LGPL
+ depends = libmad
+ depends = sqlite
+ depends = libutil-linux
+ depends = taglib
+ depends = mediainfo
+ depends = sdl
+ depends = lame
+ depends = faad2
+ depends = libcurl-gnutls
+ depends = libvorbis
+ depends = libvpx
+ depends = mpg123
+ depends = opus
+ depends = opusfile
+ depends = libogg
+ depends = libfishsound
+ depends = flac
+ depends = liboggz
+ depends = libsndfile
+ depends = alsa-lib
+ depends = libpulse
+ depends = boost
+ depends = dbus-c++
+ depends = check
+ depends = python2-pafy
+ depends = log4c
+ depends = libspotify
+ depends = python2-gmusicapi
+ depends = python-soundcloud-git
+ depends = python2-youtube-dl-git
+ provides = tizonia-all
+ conflicts = tizonia-all
+ source = tizonia-all-git::git+https://github.com/tizonia/tizonia-openmax-il.git
+ sha256sums = SKIP
+
+pkgname = tizonia-all-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a114b4757720
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Juan A. Rubio <jarubio2001@gmail.com>
+
+_githubname=tizonia-openmax-il
+pkgname=tizonia-all-git
+pkgver=0.9.0.r7.gee2765aa
+pkgrel=1
+pkgdesc="Command-line cloud music player for Linux with Spotify, Google Play Music, YouTube, SoundCloud, and Dirble support"
+arch=('x86_64')
+url="https://www.tizonia.org"
+license=('LGPL')
+depends=(
+ # official repositories:
+ 'libmad'
+ 'sqlite'
+ 'libutil-linux'
+ 'taglib'
+ 'mediainfo'
+ 'sdl'
+ 'lame'
+ 'faad2'
+ 'libcurl-gnutls'
+ 'libvorbis'
+ 'libvpx'
+ 'mpg123'
+ 'opus'
+ 'opusfile'
+ 'libogg'
+ 'libfishsound'
+ 'flac'
+ 'liboggz'
+ 'libsndfile'
+ 'alsa-lib'
+ 'libpulse'
+ 'boost'
+ 'dbus-c++'
+ 'check'
+ 'python2-pafy'
+
+ # AUR:
+ 'log4c'
+ 'libspotify'
+ 'python2-gmusicapi'
+ 'python-soundcloud-git'
+ 'python2-youtube-dl-git'
+)
+provides=('tizonia-all')
+conflicts=('tizonia-all')
+source=("${pkgname}"::"git+https://github.com/tizonia/${_githubname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ local _version="$(git tag | sort -Vr | head -n1 | sed 's/^v//')"
+ local _revision="$(git rev-list v"${_version}"..HEAD --count)"
+ local _shorthash="$(git rev-parse --short HEAD)"
+ printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+}
+
+prepare() {
+ mkdir -p "$srcdir/path"
+ # Tizonia expects Python 2
+ ln -sf /usr/bin/python2 "$srcdir/path/python"
+ ln -sf /usr/bin/python2-config "$srcdir/path/python-config"
+}
+
+build() {
+ export PATH="$srcdir/path:$PATH"
+ export PYTHON="/usr/bin/python2"
+ cd "$pkgname"
+ autoreconf -ifs
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --silent \
+ --enable-silent-rules \
+ CFLAGS='-O2 -s -DNDEBUG' \
+ CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security'
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}