summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2023-08-01 00:31:41 +0200
committergit user2023-08-01 00:31:41 +0200
commitcc97ee7c56d621193c5c689df3e2436187717e7d (patch)
tree6733122eef3b558555fce015978ccc275c4206de
parentce2b565f0109db488bbd0cbb38ca9a41e5a40f74 (diff)
downloadaur-cc97ee7c56d621193c5c689df3e2436187717e7d.tar.gz
Some fixups, but compilation fails.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD68
2 files changed, 48 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12e0ddc36610..be5e29a71a8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tizonia-all-git
pkgdesc = Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Plex servers and Chromecast devices.
- pkgver = 0.21.0.r14.ge508473f
+ pkgver = 0.22.0+28.r3903.20210110.a1e8f8bd
pkgrel = 1
url = https://www.tizonia.org
arch = x86_64
@@ -30,18 +30,18 @@ pkgbase = tizonia-all-git
depends = python-eventlet
depends = python-levenshtein
depends = log4c
- depends = libspotify
depends = python-pafy
depends = python-gmusicapi
- depends = python-soundcloud-git
- depends = python-pychromecast-git
+ depends = python-soundcloud
+ depends = python-pychromecast
depends = python-plexapi
depends = python-fuzzywuzzy
depends = python-spotipy
- provides = tizonia-all
+ provides = tizonia-all=0.22.0+28.r3903.20210110.a1e8f8bd
+ provides = tizonia=0.22.0+28.r3903.20210110.a1e8f8bd
conflicts = tizonia-all
+ conflicts = tizonia
source = tizonia-all-git::git+https://github.com/tizonia/tizonia-openmax-il.git
sha256sums = SKIP
pkgname = tizonia-all-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 24881affbf13..7f4d4243a4b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: juanrubio
+# Maintainer: dreieck (https://aur.archlinux.org/account/dreieck)
+# Contributor: juanrubio
_githubname=tizonia-openmax-il
pkgname=tizonia-all-git
-pkgver=0.21.0.r14.ge508473f
+pkgver=0.22.0+28.r3903.20210110.a1e8f8bd
pkgrel=1
pkgdesc="Command-line cloud music player for Linux with support for Spotify, Google Play Music, YouTube, SoundCloud, Plex servers and Chromecast devices."
arch=('x86_64')
@@ -33,46 +34,61 @@ depends=(
# AUR:
'log4c'
- 'libspotify'
'python-pafy'
'python-gmusicapi'
- 'python-soundcloud-git'
- 'python-pychromecast-git'
+ 'python-soundcloud'
+ 'python-pychromecast'
'python-plexapi'
'python-fuzzywuzzy'
'python-spotipy'
)
-provides=('tizonia-all')
-conflicts=('tizonia-all')
+provides=(
+ "tizonia-all=${pkgver}"
+ "tizonia=${pkgver}"
+)
+conflicts=(
+ 'tizonia-all'
+ 'tizonia'
+)
options=()
source=("${pkgname}"::git+https://github.com/tizonia/${_githubname}.git)
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- local _version="$(git tag | sort -Vr | head -n1 | sed 's/^v//')"
- local _revision="$(git rev-list v"${_version}"..HEAD --count)"
- local _shorthash="$(git rev-parse --short HEAD)"
- printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+ cd "$pkgname"
+
+ _ver="$(git describe --tags | sed -E -e 's|^[vV]||' -e 's|\-g[0-9a-f]*$||' | tr '-' '+')"
+ _rev="$(git rev-list --count HEAD)"
+ _date="$(git log -1 --date=format:"%Y%m%d" --format="%ad")"
+ _hash="$(git rev-parse --short HEAD)"
+
+ if [ -z "${_ver}" ]; then
+ error "Version could not be determined."
+ return 1
+ else
+ printf '%s' "${_ver}.r${_rev}.${_date}.${_hash}"
+ fi
}
-# prepare() {
- #command -v tizonia &> /dev/null \
- # && { \
- # echo >&2 "Please uninstall tizonia-all or tizonia-all-git before proceeding." ; \
- # echo >&2 "See https://github.com/tizonia/tizonia-openmax-il/issues/485." ; \
- # exit 1;
- # }
-#}
+prepare() {
+ if command -v tizonia > /dev/null 2>&1; then
+ plain ''
+ error "Please uninstall tizonia, tizonia-all or tizonia-all-git before proceeding."
+ error "See https://github.com/tizonia/tizonia-openmax-il/issues/485."
+ plain ''
+ exit 1
+ fi
+}
build() {
- CFLAGS='-O2 -s -DNDEBUG' \
- CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' \
- export SAMUFLAGS=-j4
- arch-meson "$pkgname" build
- samu -v -C build
+ #export CFLAGS='-O2 -s -DNDEBUG'
+ #export CXXFLAGS='-O2 -s -DNDEBUG -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security'
+ # libspotify does no longer exist & also does no longer work, so disable it
+ export SAMUFLAGS="-j$(nproc)"
+ meson setup --prefix=/usr --buildtype=plain -Dlibspotify=false "${pkgname}" build
+ samu -v -C build
}
package() {
- DESTDIR=$pkgdir samu -C build install
+ DESTDIR=$pkgdir samu -C build install
}