summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-01-30 14:41:41 +0100
committergit user2024-01-30 14:41:41 +0100
commitedc475bd520dad5d50c7f94aa89fa67f57885745 (patch)
treeafd21aeae0a28156af017700aab352c8f9fd13e3
parente7ed4345979f872a4e9f1ff7fb85b7c63d3d1f01 (diff)
downloadaur-edc475bd520dad5d50c7f94aa89fa67f57885745.tar.gz
Updated to use `taglib1`.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0deb83e737f7..fecd98420e34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tizonia-all-git
pkgdesc = Command-line cloud music player and downloader for Linux with support for YouTube, SoundCloud, Plex servers, Chromecast devices and generic streams and websites.
pkgver = 0.22.0+28.r3903.20210110.a1e8f8bd
- pkgrel = 5
+ pkgrel = 6
url = https://www.tizonia.org
arch = x86_64
license = LGPL-3.0-or-later
@@ -25,16 +25,16 @@ pkgbase = tizonia-all-git
depends = liboggz
depends = libpulse
depends = libvpx
- depends = mediainfo
+ depends = mediainfo>=0.7.65
depends = mpg123
depends = opusfile
+ depends = python>=3.5
depends = python-eventlet
depends = python-joblib
depends = python-levenshtein
- depends = python>=3
depends = sdl
depends = sqlite
- depends = taglib
+ depends = taglib1>=1.7.0
depends = youtube-dl
depends = log4c
depends = python-fuzzywuzzy
@@ -55,7 +55,9 @@ pkgbase = tizonia-all-git
options = ccache
source = tizonia::git+https://github.com/tizonia/tizonia-openmax-il.git
source = fix_chromecast_placeholders_error.patch::https://github.com/tizonia/tizonia-openmax-il/files/9795320/fix_chromecast_placeholders_error.patch.txt
+ source = use-taglib1.patch
sha256sums = SKIP
sha256sums = 8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea
+ sha256sums = 6388dadcef0273b315ae60cb1d8631021ee701082f3624fa62c3c9db357f79b5
pkgname = tizonia-all-git
diff --git a/PKGBUILD b/PKGBUILD
index 4cddc2eb7f55..f50a2d550e97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname='tizonia'
_githubname="${_pkgname}-openmax-il"
pkgname="${_pkgname}-all-git"
pkgver=0.22.0+28.r3903.20210110.a1e8f8bd
-pkgrel=5
+pkgrel=6
pkgdesc="Command-line cloud music player and downloader for Linux with support for YouTube, SoundCloud, Plex servers, Chromecast devices and generic streams and websites."
arch=(
'x86_64'
@@ -24,16 +24,16 @@ depends=(
'liboggz'
'libpulse'
'libvpx'
- 'mediainfo'
+ 'mediainfo>=0.7.65'
'mpg123'
'opusfile'
+ 'python>=3.5'
'python-eventlet'
'python-joblib' # Needed by 'usr/lib/python3.11/site-packages/tizyoutubeproxy.py', 'usr/lib/python3.11/site-packages/tiziheartproxy.py', 'usr/lib/python3.11/site-packages/tiztuneinproxy.py'.
'python-levenshtein'
- 'python>=3'
'sdl'
'sqlite'
- 'taglib'
+ 'taglib1>=1.7.0'
'youtube-dl'
# AUR:
@@ -82,10 +82,12 @@ options=()
source=(
"${_pkgname}"::git+https://github.com/tizonia/${_githubname}.git
"fix_chromecast_placeholders_error.patch::https://github.com/tizonia/tizonia-openmax-il/files/9795320/fix_chromecast_placeholders_error.patch.txt"
+ "use-taglib1.patch"
)
sha256sums=(
- 'SKIP'
- '8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea'
+ 'SKIP' # main upstream source
+ '8b538221bb0bf0d068a8502fc3bd9e2d6cea1fc9311a32d93e5aec13db646eea' # fix_chromecast_placeholders_error.patch
+ '6388dadcef0273b315ae60cb1d8631021ee701082f3624fa62c3c9db357f79b5' # use-taglib1.patch
)
if which ccache > /dev/null 2>&1; then
makedepends+=('ccache')
@@ -111,7 +113,7 @@ prepare() {
cd "${srcdir}/${_pkgname}"
- for _patch in "${srcdir}"/fix_chromecast_placeholders_error.patch; do
+ for _patch in "${srcdir}"/{fix_chromecast_placeholders_error.patch,use-taglib1.patch}; do
msg2 "Applying patch '$(basename "${_patch}")' ..."
patch -Np1 --follow-symlinks -i "${_patch}"
done
@@ -166,7 +168,8 @@ build() {
# * [2023-06-24] libspotify does no longer exist & also does no longer work, so disable it (`libspotify` would be the needed dependency), see https://aur.archlinux.org/packages/tizonia-all-git#comment-921052.
# * [2023-07-31] Google Music service is dead, but `python-gmusicapi` is still needed by `/usr/lib/python3.11/site-packages/tizgmusicproxy.py`, see https://aur.archlinux.org/packages/tizonia-all-git#comment-927188 and follow up.
# * [2023-08-01] Building tests fails with `clients/youtube/libtizyoutube/tests/check_tizyoutube.c:121:12: error: too few arguments to function ‘tiz_youtube_init’`, see https://github.com/tizonia/tizonia-openmax-il/issues/799.
- export SAMUFLAGS="-j1" # Eats a lot of ram.
+ export SAMUFLAGS="-j1" # Eats a lot of ram, so limit to one build job at a time.
+ export PKG_CONFIG_PATH='/usr/lib/taglib1/lib/pkgconfig' # Search also for taglib1.
meson setup --prefix=/usr --buildtype=plain \
-Dplayer=true \
-Dlibspotify=false \