summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-11 10:00:43 +0800
committerzxp198210052023-12-11 10:00:43 +0800
commit37b9509a67e5c1eb9a8009b4c7916b0a7faf0d27 (patch)
tree0a2f4fe32e0f6e7e9fd8c5afa399106e348c4820
parent9a8baca3afae6559b2088fa507c62f47e25413c8 (diff)
downloadaur-37b9509a67e5c1eb9a8009b4c7916b0a7faf0d27.tar.gz
update to 0.2.2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--tjmc-launcher.sh17
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3919c3ccd27b..45e958093f73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = tjmc-launcher-bin
source = LICENSE-0.2.2::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.2/LICENSE
source = tjmc-launcher.sh
sha256sums = 1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6
- sha256sums = 9f000b99bb76d849688063320e2933f2b7c1fe6fc884844edc35ba58c578adb3
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
source_aarch64 = tjmc-launcher-0.2.2-aarch64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.2/TJMC-Launcher-setup-arm64.deb
sha256sums_aarch64 = 9df087cb629bf27c0e333b48046a723862c0bb79d0bfe67b6b0e6567e911cc6a
source_x86_64 = tjmc-launcher-0.2.2-x86_64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.2/TJMC-Launcher-setup-amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 2ec45efd233c..387883ff9625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,13 +25,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6'
- '9f000b99bb76d849688063320e2933f2b7c1fe6fc884844edc35ba58c578adb3')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
sha256sums_aarch64=('9df087cb629bf27c0e333b48046a723862c0bb79d0bfe67b6b0e6567e911cc6a')
sha256sums_x86_64=('5392aedace5ab5dd59894dfd0d6e542b3bc610533a9d0220b5fce5d6a5dfd69b')
build() {
bsdtar -xf "${srcdir}/data.tar.gz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
- sed -i "s|@electronversion@|${_electronversion}|" "$srcdir/${pkgname%-bin}.sh"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/tjmc-launcher.sh b/tjmc-launcher.sh
index 09a458270cd9..2ec4412e5c4f 100644
--- a/tjmc-launcher.sh
+++ b/tjmc-launcher.sh
@@ -1,13 +1,14 @@
#!/bin/bash
-APPDIR="/usr/lib/tjmc-launcher"
-export PATH="${APPDIR}:${PATH}"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
export ELECTRON_IS_DEV=0
-#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd $APPDIR
- exec electron@electronversion@ ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd $APPDIR
- exec electron@electronversion@ ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file