summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-23 18:15:30 +0800
committerzxp198210052024-02-23 18:15:30 +0800
commit60f349c9a6f5033363059e1a9b4b3aa246587fda (patch)
treee0f98d7b132e1f0fa398aa617a6a6c3dbcb34a28
parent61c34d232c92da9953249e8093172b281c70ee59 (diff)
downloadaur-60f349c9a6f5033363059e1a9b4b3aa246587fda.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--tjmc-launcher.sh9
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35ae64a32f96..8b53e35a00b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tjmc-launcher-bin
pkgdesc = A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft.
pkgver = 0.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://launcher.tjmc.ru/
arch = aarch64
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = tjmc-launcher-bin
source = LICENSE-0.2.7::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.7/LICENSE
source = tjmc-launcher.sh
sha256sums = 1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = tjmc-launcher-0.2.7-aarch64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-arm64.deb
sha256sums_aarch64 = 56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358
source_x86_64 = tjmc-launcher-0.2.7-x86_64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 75f77a93a2eb..11b5fa6c4e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=tjmc-launcher-bin
_pkgname=TJMC-Launcher
pkgver=0.2.7
_electronversion=23
-pkgrel=1
+pkgrel=2
pkgdesc="A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft."
arch=(
'aarch64'
@@ -25,15 +25,15 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358')
sha256sums_x86_64=('b4a0666c537e9e172748d785196a8d99698244ba25d9dffc5c0f55375a188ce9')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.gz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/tjmc-launcher.sh b/tjmc-launcher.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/tjmc-launcher.sh
+++ b/tjmc-launcher.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file