summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-15 12:00:44 +0800
committerzxp198210052024-01-15 12:00:44 +0800
commit61c34d232c92da9953249e8093172b281c70ee59 (patch)
treebb7b5c258d8a3637a5e5d8f2c25b927ad9beaf64
parentebff4d2775fab8b15be6f3b6dee041fc765161ad (diff)
downloadaur-61c34d232c92da9953249e8093172b281c70ee59.tar.gz
update to 0.2.7
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
-rw-r--r--tjmc-launcher.sh13
3 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb7021d6fcd2..35ae64a32f96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tjmc-launcher-bin
pkgdesc = A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft.
- pkgver = 0.2.3
+ pkgver = 0.2.7
pkgrel = 1
url = https://launcher.tjmc.ru/
arch = aarch64
@@ -8,15 +8,15 @@ pkgbase = tjmc-launcher-bin
license = MIT
depends = hicolor-icon-theme
depends = electron23
- provides = tjmc-launcher=0.2.3
+ provides = tjmc-launcher=0.2.7
conflicts = tjmc-launcher
- source = LICENSE-0.2.3::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.3/LICENSE
+ source = LICENSE-0.2.7::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.7/LICENSE
source = tjmc-launcher.sh
sha256sums = 1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
- source_aarch64 = tjmc-launcher-0.2.3-aarch64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.3/TJMC-Launcher-setup-arm64.deb
- sha256sums_aarch64 = b19b58ad0cb1ae82bac617a3e60cb70076a284bc26d9c15ecfc70e8d59d004ab
- source_x86_64 = tjmc-launcher-0.2.3-x86_64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.3/TJMC-Launcher-setup-amd64.deb
- sha256sums_x86_64 = efc80fef0301245e76a300a6fdbc7f9cd6d8ee8ce5cc9c6959afb6f4ea3ade8e
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ source_aarch64 = tjmc-launcher-0.2.7-aarch64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-arm64.deb
+ sha256sums_aarch64 = 56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358
+ source_x86_64 = tjmc-launcher-0.2.7-x86_64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-amd64.deb
+ sha256sums_x86_64 = b4a0666c537e9e172748d785196a8d99698244ba25d9dffc5c0f55375a188ce9
pkgname = tjmc-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 06b931e466f4..75f77a93a2eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=tjmc-launcher-bin
_pkgname=TJMC-Launcher
-pkgver=0.2.3
+pkgver=0.2.7
_electronversion=23
pkgrel=1
pkgdesc="A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft."
@@ -25,16 +25,16 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
-sha256sums_aarch64=('b19b58ad0cb1ae82bac617a3e60cb70076a284bc26d9c15ecfc70e8d59d004ab')
-sha256sums_x86_64=('efc80fef0301245e76a300a6fdbc7f9cd6d8ee8ce5cc9c6959afb6f4ea3ade8e')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums_aarch64=('56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358')
+sha256sums_x86_64=('b4a0666c537e9e172748d785196a8d99698244ba25d9dffc5c0f55375a188ce9')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.gz"
- sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/tjmc-launcher.sh b/tjmc-launcher.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/tjmc-launcher.sh
+++ b/tjmc-launcher.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file