summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-12-11 15:43:13 +0100
committeroli2015-12-11 15:43:13 +0100
commit48881a06c200a3e6e1c61ff399c4d44f90530fd5 (patch)
treee0b4b05c0774e01ef78fd9d80e72d1ef244dbfaa
downloadaur-tk-resizebutton.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aebf357b5c26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 14:43:10 UTC 2015
+pkgbase = tk-resizebutton
+ pkgdesc = provides a resizeable button to be used in an HList column header.
+ pkgver = 0.01
+ pkgrel = 3
+ url = http://search.cpan.org/~xpix/Tk-ResizeButton/
+ arch = any
+ license = GPL
+ depends = tk
+ source = http://search.cpan.org/CPAN/authors/id/X/XP/XPIX/Tk-ResizeButton-0.01.tar.gz
+ md5sums = b1c782ec46e3bcb7e52fdd5909645ad2
+
+pkgname = tk-resizebutton
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82e57306dae9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Archie <xMickael@ifrance.com>
+
+pkgname=tk-resizebutton
+pkgver=0.01
+pkgrel=3
+pkgdesc="provides a resizeable button to be used in an HList column header."
+depends=('tk')
+arch=('any')
+license=('GPL')
+source=(http://search.cpan.org/CPAN/authors/id/X/XP/XPIX/Tk-ResizeButton-$pkgver.tar.gz)
+url="http://search.cpan.org/~xpix/Tk-ResizeButton/"
+md5sums=('b1c782ec46e3bcb7e52fdd5909645ad2')
+
+build() {
+ cd $srcdir/Tk-ResizeButton-$pkgver
+ perl Makefile.PL
+ make
+}
+
+package() {
+ cd $srcdir/Tk-ResizeButton-$pkgver
+ make DESTDIR=$pkgdir install
+ /usr/bin/find $pkgdir -name '.packlist' -exec rm '{}' \;
+ /usr/bin/find $pkgdir -name 'perllocal.pod' -exec rm '{}' \;
+}