summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr00tb2023-12-17 16:44:05 +0100
committerdr00tb2023-12-17 16:44:05 +0100
commit5be383c62cb194233bad4b013a20421784017ce8 (patch)
tree9b720d080dd2d1257f5e70f4f35ee195e41a369e
parent38570f79fba8dbe5397218b28f064d028f5b975b (diff)
downloadaur-5be383c62cb194233bad4b013a20421784017ce8.tar.gz
v0.0.8
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--tkey-ssh-agent.install4
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aafee017dcde..0f54a4f2cff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = tkey-ssh-agent
pkgdesc = A ssh-agent for the Tillitis TKey
- pkgver = 0.0.7
+ pkgver = 0.0.8
pkgrel = 1
url = https://github.com/tillitis/tillitis-key1-apps
+ install = tkey-ssh-agent.install
arch = i686
arch = x86_64
arch = armv6h
@@ -16,8 +17,8 @@ pkgbase = tkey-ssh-agent
provides = tkey-ssh-agent
conflicts = tkey-ssh-agent2
source = git+https://github.com/tillitis/tillitis-key1-apps.git#commit=7e18bcb
- source = git+https://github.com/tillitis/tkey-libs.git#commit=d589e5e
- source = git+https://github.com/tillitis/tkey-device-signer#commit=92a091c
+ source = git+https://github.com/tillitis/tkey-libs.git#tag=v0.0.2
+ source = git+https://github.com/tillitis/tkey-device-signer.git#tag=v0.0.8
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a206eae880ee..d1ebe46b7b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@ pkgname=tkey-ssh-agent
_pkgname=tillitis-key1-apps
_libname=tkey-libs
_appname=tkey-device-signer
-pkgver=0.0.7
+pkgver=0.0.8
+_libver=0.0.2
pkgrel=1
pkgdesc="A ssh-agent for the Tillitis TKey"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -13,9 +14,10 @@ license=('GPL2')
makedepends=('clang' 'llvm' 'lld' 'go')
conflicts=("${pkgname}2")
provides=("${pkgname}")
-source=("git+https://github.com/tillitis/tillitis-key1-apps.git#commit=7e18bcb"
- "git+https://github.com/tillitis/tkey-libs.git#commit=d589e5e"
- "git+https://github.com/tillitis/tkey-device-signer#commit=92a091c")
+install=tkey-ssh-agent.install
+source=("git+https://github.com/tillitis/${_pkgname}.git#commit=7e18bcb"
+ "git+https://github.com/tillitis/${_libname}.git#tag=v${_libver}"
+ "git+https://github.com/tillitis/${_appname}.git#tag=v${pkgver}")
b2sums=('SKIP'
'SKIP'
'SKIP')
@@ -25,11 +27,12 @@ build() {
make OBJCOPY="llvm-objcopy"
cd "${srcdir}/${_appname}"
- make OBJCOPY="llvm-objcopy"
+ make OBJCOPY="llvm-objcopy" signer/app.bin
cd "${srcdir}/${_pkgname}"
cp "${srcdir}/${_appname}/signer/app.bin" ./cmd/tkey-ssh-agent/app.bin
- make OBJCOPY="llvm-objcopy"
+ sed -i "s/tkey-ssh-agent: check-signer-hash/tkey-ssh-agent:/" Makefile
+ make OBJCOPY="llvm-objcopy" tkey-ssh-agent
}
package() {
diff --git a/tkey-ssh-agent.install b/tkey-ssh-agent.install
new file mode 100644
index 000000000000..53c551b26f32
--- /dev/null
+++ b/tkey-ssh-agent.install
@@ -0,0 +1,4 @@
+post_upgrade() {
+ printf '\033[1;33mThis release changes the Tkey identity (CDI) compared to v0.0.7, i.e., you will not have the same Ed25519 keypair derived.'
+}
+