summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2015-06-08 23:56:08 +0200
committertrya2015-06-08 23:56:08 +0200
commitf7bca1556ea3b897687a12e0ee8702347f5b4edd (patch)
treeeed264828bae99966de2c61c462123b84929e340
downloadaur-f7bca1556ea3b897687a12e0ee8702347f5b4edd.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--tkgate.diff.gzbin0 -> 8553 bytes
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a3cd9a282fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tkgate
+ pkgdesc = A digital circuit simulator with a tcl/tk-based graphical editor
+ pkgver = 1.8.7
+ pkgrel = 4
+ url = http://www.tkgate.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = imake
+ depends = tcl
+ depends = tk
+ conflicts = tkgate-beta
+ source = http://www.tkgate.org/downloads/tkgate-1.8.7.tgz
+ source = tkgate.diff.gz
+ md5sums = 628b5ca66283fc1473c9ef7300ae73c8
+ md5sums = 0eaafa98ff751c657b3adf73ea4f5bf6
+
+pkgname = tkgate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..486a1d46881d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+# Contributor: Víctor Martínez Romanos <vmromanos@gmail.com>
+
+pkgname=tkgate
+pkgver=1.8.7
+pkgrel=4
+pkgdesc="A digital circuit simulator with a tcl/tk-based graphical editor"
+arch=('i686' 'x86_64')
+url="http://www.tkgate.org"
+license=("GPL")
+makedepends=('imake')
+depends=('tcl' 'tk')
+conflicts=('tkgate-beta')
+source=("http://www.tkgate.org/downloads/$pkgname-$pkgver.tgz"
+ tkgate.diff.gz)
+md5sums=('628b5ca66283fc1473c9ef7300ae73c8'
+ '0eaafa98ff751c657b3adf73ea4f5bf6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ zcat ../tkgate.diff.gz | patch -p1
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install.man
+}
diff --git a/tkgate.diff.gz b/tkgate.diff.gz
new file mode 100644
index 000000000000..ff35872e3915
--- /dev/null
+++ b/tkgate.diff.gz
Binary files differ