summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-08-15 16:30:28 +0100
committermschubert2015-08-15 16:30:28 +0100
commit1483c311b7affeafdd74faa173d0121c240a5664 (patch)
tree233f851ceab2a76e23929d3698a0492574cc8135
downloadaur-1483c311b7affeafdd74faa173d0121c240a5664.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a69ed7f3efa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tklib
+ pkgdesc = Tklib specializes in utilities for GUI programming.
+ pkgver = 0.6
+ pkgrel = 1
+ url = http://tcllib.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = tk
+ depends = tcllib
+ source = http://core.tcl.tk/tklib/raw/tklib-0.6.tar.bz2?name=6a397dec6188148cf6a6fe290cf2bd92a9190c42
+ md5sums = 92efb16228bc98d389156a7ac4fe4770
+
+pkgname = tklib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1d3c752639d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Contributor: Thomas Dziedzic
+# Contributor: Mihai Militaru <mihai dot militaru at xmpp dot ro>
+pkgname=tklib
+pkgver=0.6
+pkgrel=1
+pkgdesc='Tklib specializes in utilities for GUI programming.'
+arch=('i686' 'x86_64')
+url='http://tcllib.sourceforge.net/'
+license=('GPL')
+depends=('tk' 'tcllib')
+source=("http://core.tcl.tk/$pkgname/raw/$pkgname-$pkgver.tar.bz2?name=6a397dec6188148cf6a6fe290cf2bd92a9190c42")
+md5sums=('92efb16228bc98d389156a7ac4fe4770')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make all
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}