summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexej Graves-Magura2018-11-14 09:56:09 -0700
committerAlexej Graves-Magura2018-11-14 09:56:09 -0700
commit3216320874fb91b52f3e54f3203a8a0984e4bbe8 (patch)
treedd2ebefc08124c52b80b67928aa69283ed880629
downloadaur-3216320874fb91b52f3e54f3203a8a0984e4bbe8.tar.gz
adding tkman to AUR
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD57
-rw-r--r--gentoo.patch62
-rw-r--r--openbsd-gui_tcl.patch11
-rw-r--r--tkman-CVE-2008-5137.patch278
-rw-r--r--tkman.sh5
6 files changed, 440 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dbad4422895
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Nov 14 16:55:23 UTC 2018
+pkgbase = tkman
+ pkgdesc = man page and info file browser
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://sourceforge.net/projects/tkman/
+ arch = any
+ license = Artistic License
+ makedepends = dos2unix
+ depends = polyglotman
+ depends = tk
+ depends = tcl
+ depends = bash
+ source = https://sourceforge.net/projects/tkman/files/tkman/2.2/tkman-2.2.tar.gz
+ source = gentoo.patch
+ source = tkman-CVE-2008-5137.patch
+ source = openbsd-gui_tcl.patch
+ source = tkman.sh
+ md5sums = 0e81735c93ab2500d6105ff33095c3e8
+ md5sums = 1d3e939dad772945a2435daff78ead76
+ md5sums = da154020b4e5e8978eb90f8b17bfa543
+ md5sums = 221053c63a1989c34ca2191d7c58674d
+ md5sums = 41ffdb3a149f81f4e0a7555afcfe48ca
+
+pkgname = tkman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c3939133d01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Alexej Magura <agm2819@*gmail*>
+
+pkgname=tkman
+pkgver=2.2
+pkgrel=1
+pkgdesc="man page and info file browser"
+#epoch=0
+arch=(any)
+url="https://sourceforge.net/projects/tkman/"
+license=('Artistic License')
+depends=(polyglotman tk tcl bash)
+makedepends=(dos2unix)
+source=("https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+ "gentoo.patch"
+ "tkman-CVE-2008-5137.patch"
+ "openbsd-gui_tcl.patch"
+ tkman.sh)
+md5sums=(0e81735c93ab2500d6105ff33095c3e8
+ 1d3e939dad772945a2435daff78ead76
+ da154020b4e5e8978eb90f8b17bfa543
+ 221053c63a1989c34ca2191d7c58674d
+ 41ffdb3a149f81f4e0a7555afcfe48ca)
+
+prepare()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ patch < "$srcdir"/gentoo.patch
+ patch -p1 < "$srcdir"/tkman-CVE-2008-5137.patch
+ dos2unix gui.tcl
+ patch < "$srcdir"/openbsd-gui_tcl.patch
+ #mv -v -- $pkgname $pkgname.tcl
+ #cp -v -- "$srcdir"/tkman.sh tkman
+ mv -v -- README-tkman README
+ mv -v -- ANNOUNCE-tkman.txt ANNOUNCE
+ cp -v -- "$srcdir"/tkman.sh .
+
+ sed -i '${s|$| sh /usr/share/tkman/tkman.tcl|}' tkman.sh
+}
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ make WISH="/usr/bin/wish" BINDIR="/usr/bin"
+ sed -i 's|/bin/sh|/usr/bin/sh|' $pkgname
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir"/usr/{share/$pkgname/doc,bin}
+ install -m644 tkman "$pkgdir"/usr/share/$pkgname/$pkgname.tcl
+ install -m755 tkman.sh "$pkgdir"/usr/bin/tkman
+ #echo "bash /usr/share/$pkgname/$pkgname.tcl" >> "$pkgdir"/usr/bin/tkman
+ install -m644 -t "$pkgdir"/usr/share/$pkgname/doc CHANGES MANIFEST README manual.html
+ install -m644 contrib/TkMan.xpm "$pkgdir"/usr/share/pixmaps
+}
+# vim:set ts=2 sw=2 et:
diff --git a/gentoo.patch b/gentoo.patch
new file mode 100644
index 000000000000..92a275361c8f
--- /dev/null
+++ b/gentoo.patch
@@ -0,0 +1,62 @@
+--- tkman-2.2/Makefile.org 2003-12-07 13:26:37.642164439 +0100
++++ tkman-2.2/Makefile 2003-12-07 13:30:39.135540314 +0100
+@@ -25,13 +25,13 @@
+
+ ### you need to localize the paths on these lines
+
+-WISH = /usr/local/bin/wish8.4
++WISH = /usr/bin/wish
+ #WISH = /usr/sww/tcl-8.4/bin/wish
+ #WISH = /private/share/bin/wish8.4
+
+ # the executable `tkman' is placed in BINDIR
+ # this should be a directory that's in your bin PATH
+-BINDIR = /usr/local/bin
++BINDIR = ${DESTDIR}/usr/bin
+ #BINDIR = /private/share/bin
+
+
+@@ -80,7 +80,7 @@
+ # will examine for matches if a search in the usual locations fails while searching
+ # for a man pages and displaying its associated binaries (if any).
+ # Use this feature carefully as a large number of directories can slow down startup.
+-mastermen = "/usr/man /usr/local/man"
++mastermen = "/usr/share/man /usr/local/man"
+ #mastermen = "/usr/man /usr/local/man /usr/sww/man /usr/share/man /usr/kerberos/man"
+ masterbin = "/usr/bin /usr/local/bin"
+ #masterbin = "/usr/bin /usr/local/bin /usr/sww/bin /usr/sww/share/bin /usr/sww/share/X11R5/bin"
+@@ -203,7 +203,7 @@
+ # BY DEFAULT OFF
+ glimpse = ""
+ # Glimpse on, with Boolean scope set to entire file
+-glimpse = "glimpse -W"
++#glimpse = "glimpse -W"
+ # give the full path, if you'd like
+ #glimpse = /usr/sww/bin/glimpse
+ # variations (refer to the Glimpse manual page)
+@@ -228,11 +228,11 @@
+ #glimpseindex = "glimpseindex -o -B"
+ # To shorten most index build times by incrementally building index when possible.
+ # For me, this drops indexing time from ~25 minutes to ~3 minutes, depending
+-glimpseindex = "glimpseindex -o -B -f"
++#glimpseindex = "glimpseindex -o -B -f"
+ # -M 8 gives 8MB of main memory instead of default 2, which speeds up indexing, maybe
+ #glimpseindex = "glimpseindex -o -B -f -M 8"
+ # if you don't want give the power to index, disable glimpseindex here
+-#glimpseindex = ""
++glimpseindex = ""
+ #glimpseindex = "/usr/sww/bin/glimpseindex -o -B"
+ # compressed manual pages are handled automatically; don't add -z to above
+
+@@ -289,9 +289,9 @@
+ rman = rman
+ #rman = /usr/local/bin/rman
+
+-apropos = {man -k}
++#apropos = {man -k}
+ # Linux uses a shell script instead:
+-#apropos = apropos
++apropos = apropos
+ # if don't have apropos (maybe on Windoze)
+ #apropos = ""
+
diff --git a/openbsd-gui_tcl.patch b/openbsd-gui_tcl.patch
new file mode 100644
index 000000000000..53bd133b550c
--- /dev/null
+++ b/openbsd-gui_tcl.patch
@@ -0,0 +1,11 @@
+$OpenBSD: patch-gui_tcl,v 1.1 2011/01/05 17:34:17 stu Exp $
+--- gui.tcl.orig Fri Dec 10 20:44:34 2010
++++ gui.tcl Fri Dec 10 20:46:05 2010
+@@ -746,6 +746,7 @@ proc manManTabSet {w} {
+ set repstr "ETRNIOASM aaabcdeeeefghiijklmnnooprrsttuy"; set replen [string length $repstr]
+
+ set rm [expr {[winfo width $t]-2*[$t cget -padx]-10}]
++ if {$rm <= 150} { set rm 151 }
+ $t tag configure info -tabs [list 0.3i $rm right]
+ $t tag configure census -tabs [list [expr {$rm-150}] right $rm right]
+ $t tag configure high -tabs [list $rm right]
diff --git a/tkman-CVE-2008-5137.patch b/tkman-CVE-2008-5137.patch
new file mode 100644
index 000000000000..2e9bcc2828d6
--- /dev/null
+++ b/tkman-CVE-2008-5137.patch
@@ -0,0 +1,278 @@
+diff -urN tkman-2.2~/Makefile tkman-2.2/Makefile
+--- tkman-2.2~/Makefile 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/Makefile 2008-12-05 17:37:55.000000000 -0600
+@@ -97,7 +97,7 @@
+ # at the closest DPI in this list
+ dpis = "75 100"
+
+-
++manxlongtmp = [exec mktemp -p /tmp tkman.XXXXXXXXXX]
+ # # # MACHINE DEPENDENCIES # # #
+
+ #manformat = {tbl | neqn | nroff -man }
+@@ -113,7 +113,7 @@
+ # Lines are cached in .../man/cat<n>@<line-length>;
+ # that is, the line length is appended to the usual cache directory names
+ #manformat = {groff -te -Tascii -man /tmp/ll -}
+-manformat = {groff -te -Tlatin1 -man /tmp/ll -}
++manformat = "groff -te -Tlatin1 -mandoc $$manx(longtmp) -"
+ # Ultrix users should uncomment the following line (you don't have eqn)
+ #manformat = {tbl | nroff -man }
+ # HP-UX uses a number of macros that groff doesn't define, so use the builtin nroff
+@@ -362,6 +362,7 @@
+ echo 'set man(texinfodir) $(texinfodir)' >> tkman
+ echo 'set man(gzgrep) $(gzgrep)' >> tkman
+ echo 'set man(rfcdir) $(rfcdir)' >> tkman
++ echo 'set manx(longtmp) $(manxlongtmp)' >> tkman
+ echo 'set man(format) $(manformat)' >> tkman
+ echo 'set man(printers) $(printers)' >> tkman
+ echo 'set manx(dpis) $(dpis)' >> tkman
+diff -urN tkman-2.2~/contrib/outline.tcl tkman-2.2/contrib/outline.tcl
+--- tkman-2.2~/contrib/outline.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/contrib/outline.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -71,7 +71,7 @@
+
+ text [set t .inv] -font {Times 12 {}} -wrap word -borderwidth 3 -padx 5 -pady 5 -yscrollcommand "[set v .v] set"
+ set finv [expr 1-[catch {$t tag configure invis -elide 1}]]
+- if !$finv { puts "you must apply the elided text patches first"; exit 0 }
++ if !$finv { puts "you must apply the elided text patches first"; CLEANUP; exit 0 }
+
+ scrollbar $v -orient vertical -command "$t yview"
+
+diff -urN tkman-2.2~/contrib/remote.tcl tkman-2.2/contrib/remote.tcl
+--- tkman-2.2~/contrib/remote.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/contrib/remote.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -26,6 +26,7 @@
+ if {$res=="1"} {set ready 1}
+ } elseif {[string match "*insecure*" info]} {
+ puts stderr "can't talk to an insecure server -- see send(n)"
++ CLEANUP
+ exit 1
+ }
+ }
+diff -urN tkman-2.2~/contrib/tkmanclient tkman-2.2/contrib/tkmanclient
+--- tkman-2.2~/contrib/tkmanclient 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/contrib/tkmanclient 2008-12-05 17:37:55.000000000 -0600
+@@ -60,7 +60,7 @@
+ }
+
+ set tkman [ check_for_tkman ]
+-if { $tkman == 0 } { puts stderr "couldnt start tkman!"; exit 1; }
++if { $tkman == 0 } { puts stderr "couldnt start tkman!"; CLEANUP; exit 1; }
+
+ set apropos 0
+ set instNew 0
+diff -urN tkman-2.2~/database.tcl tkman-2.2/database.tcl
+--- tkman-2.2~/database.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/database.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -41,6 +41,7 @@
+ if {![llength $manx(manList)]} {
+ puts stderr "Can't find any man pages!"
+ puts stderr "MANPATH = $env(MANPATH)"
++ CLEANUP
+ exit 1
+ }
+
+diff -urN tkman-2.2~/gui.tcl tkman-2.2/gui.tcl
+--- tkman-2.2~/gui.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/gui.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -66,7 +66,7 @@
+ wm protocol $w WM_SAVE_YOURSELF "manSave"
+ wm command $w [concat $argv0 $argv]
+ # aborts without saving .tkman
+- wm protocol $w WM_DELETE_WINDOW {exit 0}
++ wm protocol $w WM_DELETE_WINDOW {CLEANUP; exit 0}
+
+ # some braindead window managers ignore iconposition requests after window is iconified, so special setting here
+ if {[regexp $manx(posnregexp) $manx(iconposition) all x y]} {wm iconposition $w $x $y}
+@@ -221,7 +221,7 @@
+ -command "incr stat(checkpoint); manSave; manWinstdout \$curwin {[bolg $manx(startup) ~] updated}"
+ # if {!$dup} { ... but menu shared!
+ $m add separator
+- $m add command -label "Quit, don't update $manx(startup-short)" -command "exit 0"
++ $m add command -label "Quit, don't update $manx(startup-short)" -command "CLEANUP; exit 0"
+ # }
+ }
+
+@@ -537,8 +537,8 @@
+ "
+
+ ### quit
+- button $w.quit -text "Quit" -command "manSave; exit 0" -padx 4
+- if {!$manx(quit)} {$w.quit configure -command "exit 0"}
++ button $w.quit -text "Quit" -command "manSave; CLEANUP; exit 0" -padx 4
++ if {!$manx(quit)} {$w.quit configure -command "CLEANUP; exit 0"}
+ if {$dup} {
+ $w.quit configure -text "Close" -command "
+ destroy $w; incr manx(outcnt) -1; manOutput
+diff -urN tkman-2.2~/manpath.tcl tkman-2.2/manpath.tcl
+--- tkman-2.2~/manpath.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/manpath.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -138,6 +138,7 @@
+ if {![llength $manx(paths)]} {
+ if {$manx(manpath-warnings) ne ""} {puts stderr $manx(manpath-warnings)}
+ puts stderr "NO VALID DIRECTORIES IN MANPATH!\a"
++ CLEANUP
+ exit 1
+ }
+ }
+diff -urN tkman-2.2~/prefs.tcl tkman-2.2/prefs.tcl
+--- tkman-2.2~/prefs.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/prefs.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -365,7 +365,7 @@
+ pack $g.nroffsave $g.columns $g.fsstnd-always $g.texinfodir $g.recentdays $g.preferTexinfo $g.tryfuzzy $g.preferGNU \
+ $g.maxglimpse $g.maxglimpseexcerpt $g.indexglimpse $g.glimpsestrays $g.indexalso \
+ -fill x -pady 3 -padx 4
+- if {![string match "*groff*/tmp/ll -*" $man(format)]} {pack forget $g.columns}
++ if {![string match "*groff*$manx(longtmp) -*" $man(format)]} {pack forget $g.columns}
+
+
+
+@@ -791,7 +791,7 @@
+ bold {set weight "bold"}
+ italics {set slant "italic"}
+ bold-italics {set weight "bold"; set slant "italic"}
+- default {puts stderr "nonexistent style: $style"; exit 1}
++ default {puts stderr "nonexistent style: $style"; CLEANUP; exit 1}
+ }
+
+ # specify s,m,l within small,medium,large; or set absolute point size
+diff -urN tkman-2.2~/taputils.tcl tkman-2.2/taputils.tcl
+--- tkman-2.2~/taputils.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/taputils.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -98,7 +98,7 @@
+ proc assert {bool msg {boom 0}} {
+ if {!$bool} {
+ puts stderr $msg
+- if {$boom} {exit 1}
++ if {$boom} {CLEANUP; exit 1}
+ }
+ }
+
+diff -urN tkman-2.2~/tkman.tcl tkman-2.2/tkman.tcl
+--- tkman-2.2~/tkman.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/tkman.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -539,7 +539,7 @@
+ proc manMenuFit {m} {
+ global man manx
+
+- if {[winfo class $m]!="Menu"} {puts stderr "$m not of Menu class"; exit 1}
++ if {[winfo class $m]!="Menu"} {puts stderr "$m not of Menu class"; CLEANUP; exit 1}
+ if {[$m index last] eq "none"} return
+
+ set sh [winfo screenheight $m]
+@@ -1827,7 +1827,7 @@
+ if {$inx<[llength $manx(binvars)]} {
+ after 1000 manBinCheck $inx $err
+ } else {
+- if {$err} {exit 1}
++ if {$err} {CLEANUP; exit 1}
+ .occ entryconfigure "Statistics*" -state normal
+ }
+
+@@ -1850,6 +1850,7 @@
+ }
+ puts -nonewline "tkman"
+ foreach line [split [textmanip::linebreak $helptxt 70] "\n"] { puts "\t$line" }
++ CLEANUP
+ exit 0
+ }
+ -M {set env(MANPATH) $val; incr i}
+@@ -1868,11 +1869,11 @@
+ -start* {set manx(startup) $val; incr i}
+ -data* {puts stderr "-database option obsolete: database kept in memory"; incr i}
+ --v* -
+- -v* {puts stdout "TkMan v$manx(version) of $manx(date)"; exit 0}
++ -v* {puts stdout "TkMan v$manx(version) of $manx(date)"; CLEANUP; exit 0}
+ -t* {set manx(title) $val; incr i}
+ -d* {set manx(debug) 1; set manx(quit) 0; set manx(iconify) 0}
+ -nod* {set manx(debug) 0}
+- -* {puts stdout "[file tail $argv0]: unrecognized option: $arg"; exit 1}
++ -* {puts stdout "[file tail $argv0]: unrecognized option: $arg"; CLEANUP; exit 1}
+ default {
+ after 2000 manShowMan $arg {{}} .man
+ # permit several??? add extras to History?
+@@ -1888,6 +1889,7 @@
+ proc ASSERT {args} {
+ if {![uplevel 1 eval $args]} {
+ puts "ASSERTION VIOLATED: $args"
++ CLEANUP
+ exit 1
+ }
+ }
+@@ -1906,7 +1908,10 @@
+ set manx(lastclick) $clicknow
+ }
+
+-
++proc CLEANUP {} {
++ global manx
++ if { [file exists $manx(longtmp)] == 1 } { file delete $manx(longtmp) }
++}
+
+
+ ##################################################
+@@ -1919,6 +1924,7 @@
+ if {[package vcompare [info tclversion] $manx(mintcl)]==-1 || [package vcompare $tk_version $manx(mintk)]==-1} {
+ puts -nonewline stderr "Tcl $manx(mintcl)/Tk $manx(mintk) minimum versions required. "
+ puts stderr "You have Tcl [info tclversion]/Tk $tk_version"
++ CLEANUP
+ exit 1
+ } elseif {int([info tclversion])-int($manx(mintcl))>=1 || int($tk_version)-int($manx(mintk))>=1} {
+ puts stderr "New major versions of Tcl and/or Tk may have introduced\nincompatibilies in TkMan.\nCheck the TkMan home site for a possible new version.\n"
+@@ -2111,7 +2117,6 @@
+ set manx(line-scale) 1; set manx(screen-scale) 45; set manx(page-scale) [expr int(60*1.5)]
+ set man(error-effect) "bell & flash"; set manx(error-effect-v) [set manx(error-effect-t) {"bell & flash" "bell" "flash" "none"}]
+ set man(columns) 65; set manx(columns-v) {65 90 130 5000}; set manx(columns-t) {"65 (most compatible)" 90 130 "wrap to screen width"}; # no one would want shorter lines
+-set manx(longtmp) /tmp/ll
+ set man(volcol) 4.0c; set manx(volcol-v) {0 1.5c 2.0c 2.5c 3.0c 3.5c 4.0c 4.5c 5.0c 7.5c 10.0c}; set manx(volcol-t) {"no columns" "1.5 cm" "2 cm" "2.5 cm/~1 inch" "3 cm" "3.5 cm" "4 cm" "4.5 cm" "5.0 cm/~2 inches" "7.5 cm" "10 cm"}
+ set man(apropostab) "4.5c"; set manx(apropostab-v) {0 3.0c 4.0c 4.5c 5.0c 5.5c 6.0c 7.5c 10.0c}; set manx(apropostab-t) {"none" "3 cm" "4 cm" "4.5 cm" "5 cm" "5.5 cm" "6 cm" "7.5 cm" "10 cm"}
+ #set man(showoutsub) ""
+@@ -2258,7 +2263,7 @@
+ regexp {(\d\d\d\d)/(\d\d)/(\d\d)} {$Date: 2003/04/01 23:02:52 $} manx(date) y m d
+ set manx(mtime) [clock scan "$m/$d/$y"]
+ set manx(stray-warnings) ""
+-if {[catch {set default(manList) 0}]} {puts "\aBLT conflicts with TkMan."; exit 1}
++if {[catch {set default(manList) 0}]} {puts "\aBLT conflicts with TkMan."; CLEANUP; exit 1}
+ set manx(manList) $man(manList)
+ set manx(manTitleList) $man(manTitleList)
+ set manx(userconfig) "### your additions go below"
+@@ -2385,6 +2390,7 @@
+ if {[string match "#!*" [gets $fid line]]} {
+ puts stderr "$manx(startup) looks like an executable."
+ puts stderr "You should delete it, probably."
++ CLEANUP
+ exit 1
+ }
+
+@@ -2613,6 +2619,7 @@
+
+ if {[llength $man(manList)]!=[llength $man(manTitleList)]} {
+ puts stderr "Length of section abbreviations differs from length of section titles:\n\nlength [llength $man(manList)]:\t$man(manList)\n\nlength [llength $man(manTitleList)]:\t$man(manTitleList)"
++ CLEANUP
+ exit 1
+ }
+
+diff -urN tkman-2.2~/tkmandesc.tcl tkman-2.2/tkmandesc.tcl
+--- tkman-2.2~/tkmandesc.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/tkmandesc.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -152,6 +152,7 @@
+ foreach n [concat $from $to] {
+ if {[lsearch $mani(manList) $n]==-1} {
+ puts stderr "$cmd: Section letter `$n' doesn't exist."
++ CLEANUP
+ exit 1
+ }
+ }
+diff -urN tkman-2.2~/version.tcl tkman-2.2/version.tcl
+--- tkman-2.2~/version.tcl 2003-04-01 17:31:38.000000000 -0600
++++ tkman-2.2/version.tcl 2008-12-05 17:37:55.000000000 -0600
+@@ -80,7 +80,7 @@
+
+ ### collect diffs
+ # diff needs at least one of them to be a real file. want text of previous version around anyhow
+- set tmpf /tmp/tkman[pid]
++ set tmpf [exec mktemp -p /tmp tkman.XXXXXXXXXX]
+ # $man(changeleft) $man(zaphy) -- obsolete options
+ set format "$man(format) | $manx(rman) -f ASCII -N"
+ #puts "creating $tmpf (old)"
diff --git a/tkman.sh b/tkman.sh
new file mode 100644
index 000000000000..4705f36045f0
--- /dev/null
+++ b/tkman.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/sh
+_MANPATH=
+test -z "$MANPATH" && _MANPATH="/usr/share/man" || _MANPATH="$MANPATH"
+
+MANPATH="$_MANPATH"