summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 18:05:16 +0100
committerBartłomiej Piotrowski2018-01-05 18:05:16 +0100
commit10855199de8580804cc06f822a97eb456743a733 (patch)
treeb59fed0f5bf789ad06b4a98409855aee25674dd9
downloadaur-10855199de8580804cc06f822a97eb456743a733.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79a919a020e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tksystray
+ pkgdesc = tksystray is compatible with freedesktop.org standards systray for Tk
+ pkgver = 0.1
+ pkgrel = 7
+ url = http://tkabber.jabber.ru/tksystray
+ arch = x86_64
+ license = GPL
+ depends = tcl
+ depends = tk
+ depends = imlib
+ source = https://sources.archlinux.org/other/community/tksystray/tksystray_0.1.orig.tar.gz
+ md5sums = d1784d2f786304bd6eaa82512fd5cf1c
+
+pkgname = tksystray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7798c0b5017f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Pavel Borzenkov <pavel.borzenkov@gmail.com>
+
+pkgname=tksystray
+pkgver=0.1
+pkgrel=7
+pkgdesc="tksystray is compatible with freedesktop.org standards systray for Tk"
+arch=('x86_64')
+url="http://tkabber.jabber.ru/tksystray"
+license=("GPL")
+depends=(tcl tk imlib)
+source=(https://sources.archlinux.org/other/community/tksystray/tksystray_$pkgver.orig.tar.gz)
+md5sums=('d1784d2f786304bd6eaa82512fd5cf1c')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --with-tcl=/usr/lib --with-tk=/usr/lib
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/$pkgname-$pkgver
+ cp -rf libtray.so "$pkgdir"/usr/lib/$pkgname-$pkgver
+ cp -rf pkgIndex.tcl "$pkgdir"/usr/lib/$pkgname-$pkgver
+}