summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJules P?nuchot2022-03-15 10:35:04 +0100
committerJules P?nuchot2022-03-15 10:35:04 +0100
commit507683ceee55c6875b47dbd2beb554c90f3fc5fb (patch)
treebbedd477065204009a1b26e3920eb6ee3d4bc856
downloadaur-507683ceee55c6875b47dbd2beb554c90f3fc5fb.tar.gz
Added tl-optional
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..695e89b40e9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tl-optional-git
+ pkgdesc = C++11/14/17 std::optional with functional-style extensions and reference support
+ pkgver = v1.0.0.r20.gc28fcf7
+ pkgrel = 1
+ url = https://github.com/TartanLlama/optional
+ arch = any
+ license = CC0
+ makedepends = cmake
+ provides = tl-optional
+ conflicts = tl-optional
+ source = tl-optional-git::git+https://github.com/TartanLlama/optional.git#branch=master
+ sha256sums = SKIP
+
+pkgname = tl-optional-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e704665364f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jules PĂ©nuchot <jules@penuchot.com>
+
+_name=tl-optional
+_author=TartanLlama
+
+pkgname=${_name}-git
+pkgver=v1.0.0.r20.gc28fcf7
+pkgrel=1
+pkgdesc="C++11/14/17 std::optional with functional-style extensions and reference support "
+arch=('any')
+url="https://github.com/${_author}/optional"
+license=('CC0')
+
+depends=()
+makedepends=('cmake')
+provides=('tl-optional')
+conflicts=('tl-optional')
+
+source=("$pkgname::git+https://github.com/${_author}/optional.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cmake -B build -S ${pkgname} \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_TESTING=OFF \
+ -Wno-dev
+}
+
+package() {
+ make -C build DESTDIR=$pkgdir install
+}