summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Barri2020-12-15 09:20:30 +1100
committerDavid Barri2020-12-15 09:20:30 +1100
commit1d70e0da328fa98d54e8de757e7458005052bfe8 (patch)
treee921d7a62bd99d89a3554c850ed0f55b18df91e8
downloadaur-1d70e0da328fa98d54e8de757e7458005052bfe8.tar.gz
First cut
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--Makefile12
-rw-r--r--PKGBUILD24
-rwxr-xr-xtla2json2
5 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45655721c070
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tla2json
+ pkgdesc = Convert TLA+ output and values into JSON.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/japgolly/tla2json
+ arch = x86_64
+ license = Apache
+ depends = java-runtime
+ noextract = tla2json.jar
+ source = https://github.com/japgolly/tla2json/releases/download/v1.0.0/tla2json.jar
+ source = tla2json
+ sha256sums = 2054d7f60521fd6a8dc974b927d69a380ba867b000e3d71dc46fafd8c291c22d
+ sha256sums = be4a88d33ab6f20c09270b22830b08f37fd059e888b9c272f0fe6c088337e92f
+
+pkgname = tla2json
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cac3b854fcf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.*
+pkg
+src
+tla2json.jar
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..b84c8e9dfaad
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+.PHONY: pre post clean
+
+pre:
+ makepkg -g
+
+post:
+ makepkg --verifysource -f
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf /tmp/makepkg/tla2json
+ git clean -fX
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12f78d2ec603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: David Barri <japgolly@gmail.com>
+pkgname=tla2json
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Convert TLA+ output and values into JSON."
+arch=('x86_64')
+url="https://github.com/japgolly/tla2json"
+license=('Apache')
+depends=('java-runtime')
+noextract=('tla2json.jar')
+source=(
+ "https://github.com/japgolly/tla2json/releases/download/v$pkgver/tla2json.jar"
+ tla2json
+)
+sha256sums=(
+ '2054d7f60521fd6a8dc974b927d69a380ba867b000e3d71dc46fafd8c291c22d'
+ 'be4a88d33ab6f20c09270b22830b08f37fd059e888b9c272f0fe6c088337e92f'
+)
+
+package() {
+ mkdir -p "$pkgdir/usr/share/java" "$pkgdir/usr/bin"
+ install -m644 tla2json.jar "$pkgdir/usr/share/java"
+ install -m755 tla2json "$pkgdir/usr/bin"
+}
diff --git a/tla2json b/tla2json
new file mode 100755
index 000000000000..0472a519de0d
--- /dev/null
+++ b/tla2json
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec java -jar /usr/share/java/tla2json.jar "$@" \ No newline at end of file