summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchrottfresse2015-11-28 15:44:14 +0100
committerSchrottfresse2015-11-28 15:44:14 +0100
commit9b3b71e4e212737c4d615796f5f172a75f811412 (patch)
treea8fb7f6ca153e6fa9d18e4a898892464ec021418
downloadaur-9b3b71e4e212737c4d615796f5f172a75f811412.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--tlclient.desktop11
-rw-r--r--tlclient.install3
-rw-r--r--tlclient.pngbin0 -> 10835 bytes
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faa4b6f92237
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = tlclient
+ pkgdesc = A remote desktop application
+ pkgver = 4.5.0
+ pkgrel = 1
+ url = https://www.cendio.com/thinlinc/download
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = custom:cendio
+ depends = python2
+ depends = pygtk
+ depends = openssh
+ depends = libx11
+ depends = alsa-lib
+ depends = zlib
+ optdepends = cups: required for remote printing
+ optdepends = python2-ldap: auth against ldap
+ source = tlclient.desktop
+ source = tlclient.png
+ sha256sums = 3db307225f95453eeac89f4fcd4618efd01a977cc66998ba11fc22f97c194004
+ sha256sums = bb7cdf717ba1ee425be21d6bce245a17f2ba798b7202d9189fc964a408e3208a
+ source_i686 = https://www.cendio.com/downloads/clients/tl-4.5.0-4930-client-linux-dynamic-i686.tar.gz
+ sha256sums_i686 = 6ae74fa61fd7d69d200bdd9c4fa986dd889ad6bb2266e0a8d14873062852d42f
+ source_x86_64 = https://www.cendio.com/downloads/clients/tl-4.5.0-4930-client-linux-dynamic-x86_64.tar.gz
+ sha256sums_x86_64 = 2485a72e4f4264ad9b0f5b51de1a1a84a55ca9cb321836376861a09c8ad8b3d4
+ source_armv7h = https://www.cendio.com/downloads/clients/tl-4.5.0-4930-client-linux-dynamic-armhf.tar.gz
+ sha256sums_armv7h = 1365b0b1ff92bdb7a2cfb4fd9238cf805d2ff696bb759d0c2f3993e107416921
+
+pkgname = tlclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37529a36ec49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#Maintainer: Schrottfresse <schrottfresse at gmx dot de>
+
+pkgname=tlclient
+pkgver=4.5.0
+pkgrel=1
+pkgdesc="A remote desktop application"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://www.cendio.com/thinlinc/download"
+license=('custom:cendio')
+depends=('python2' 'pygtk' 'openssh' 'libx11' 'alsa-lib' 'zlib')
+optdepends=('cups: required for remote printing'
+ 'python2-ldap: auth against ldap')
+
+source=('tlclient.desktop' 'tlclient.png')
+sha256sums=(
+ '3db307225f95453eeac89f4fcd4618efd01a977cc66998ba11fc22f97c194004'
+ 'bb7cdf717ba1ee425be21d6bce245a17f2ba798b7202d9189fc964a408e3208a'
+ )
+
+source_x86_64=("https://www.cendio.com/downloads/clients/tl-$pkgver-4930-client-linux-dynamic-x86_64.tar.gz")
+sha256sums_x86_64=('2485a72e4f4264ad9b0f5b51de1a1a84a55ca9cb321836376861a09c8ad8b3d4')
+
+source_i686=("https://www.cendio.com/downloads/clients/tl-$pkgver-4930-client-linux-dynamic-i686.tar.gz")
+sha256sums_i686=('6ae74fa61fd7d69d200bdd9c4fa986dd889ad6bb2266e0a8d14873062852d42f')
+
+source_armv7h=("https://www.cendio.com/downloads/clients/tl-$pkgver-4930-client-linux-dynamic-armhf.tar.gz")
+sha256sums_armv7h=('1365b0b1ff92bdb7a2cfb4fd9238cf805d2ff696bb759d0c2f3993e107416921')
+
+package() {
+ cd $srcdir/tl-$pkgver-4930-client-linux-dynamic-*
+ install -Dm644 "lib/tlclient/EULA.txt" "$pkgdir/usr/share/licenses/$pkgname/EULA.txt"
+ install -m644 "lib/tlclient/open_source_licenses.txt" "$pkgdir/usr/share/licenses/$pkgname/open_source_licenses.txt"
+
+ cp -R lib "$pkgdir/usr/"
+
+ install -Dm644 "etc/tlclient.conf" "$pkgdir/etc/tlclient.conf"
+ install -Dm755 "bin/tlclient" "$pkgdir/usr/bin/tlclient"
+ install -Dm755 "bin/tlclient-openconf" "$pkgdir/usr/bin/tlclient-openconf"
+
+ install -Dm644 "../tlclient.desktop" "$pkgdir/usr/share/applications/tlclient.desktop"
+ install -Dm644 "../tlclient.png" "$pkgdir/usr/share/$pkgname/tlclient.png"
+}
diff --git a/tlclient.desktop b/tlclient.desktop
new file mode 100644
index 000000000000..2c10f98bc02d
--- /dev/null
+++ b/tlclient.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Categories=Network;
+Version=4.5.0
+Name=ThinLinc Client
+GenericName=Remote desktop application
+Comment=The ThinLinc client - a remote desktop application
+Exec=/usr/bin/tlclient
+Icon=/usr/share/tlclient/tlclient.png
+Terminal=false
+Type=Application
+NoDisplay=false
diff --git a/tlclient.install b/tlclient.install
new file mode 100644
index 000000000000..e5e086474756
--- /dev/null
+++ b/tlclient.install
@@ -0,0 +1,3 @@
+post_install() {
+ xdg-desktop-menu forceupdate
+}
diff --git a/tlclient.png b/tlclient.png
new file mode 100644
index 000000000000..71e54e33b3a9
--- /dev/null
+++ b/tlclient.png
Binary files differ