summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2022-02-25 05:40:56 -0700
committernot_anonymous2022-02-25 05:40:56 -0700
commite0028aa952848b6fee1e0b6295f8575d6df7bd31 (patch)
treec4c484687e1cd79a4acf66455368033540aab490
parent41ca42e391fece642848cd5b115d93a3950eb0da (diff)
downloadaur-e0028aa952848b6fee1e0b6295f8575d6df7bd31.tar.gz
Updated
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--tlf.desktop13
3 files changed, 29 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 497825dc6bce..f3bbf7bc4ef6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = tlf-git
- pkgdesc = a console mode networked logging and contest program for hamradio
- pkgver = 1.3.0.r1.g3535aa1
- pkgrel = 1
- url = https://tlf.github.com/
+ pkgdesc = Ham Radio networked logging and contest program - CLI
+ pkgver = 1.4.1.r245.g2b5c837
+ pkgrel = 2
+ url = https://tlf.github.io/
arch = i686
arch = x86_64
license = GPL
makedepends = autoconf
makedepends = automake
makedepends = pkg-config
- depends = hamlib
+ depends = xfce4-terminal
+ depends = hamlib-git
depends = xmlrpc-c
depends = hamradio-menus
optdepends = cwdaemon: transmitting cw
+ optdepends = winkeydaemon: transmitting cw
optdepends = cty: country files
optdepends = joe: editing qsos
optdepends = xplanet: mapped qso display
+ optdepends = sox: audio signal handling
optdepends = fldigi: digital modes/modem & gui/display
provides = tlf
conflicts = tlf
@@ -24,13 +27,12 @@ pkgbase = tlf-git
source = tlf.png
source = tlf.1
md5sums = SKIP
- md5sums = b83cca73cea288ed139993efceb245b5
+ md5sums = ace42b89f5e7a686e4adc8b457f266f7
md5sums = f148583e02660cb430f638fd8f71f452
md5sums = b706428f41d32bd5f4f6f671057638c0
sha256sums = SKIP
- sha256sums = cc7b5bcf825ea342d126a54a778c4f837ea0da4a12101383f99282041eb5d574
+ sha256sums = babe8eeda21b9d55966ef74fcf7aa2eef50317b94576f271e5d5ff580f9f5327
sha256sums = 0ddcde4f0dfa98540d4314660108ed49bfa0bc3d8b87cb46906dfd6f12be2497
sha256sums = 766253a6f4b1d7e0526366875a46e220d637665c3c44e551f8d3db4ed88aaf81
pkgname = tlf-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 09a4f9a3ff49..178d79934866 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,29 @@
pkgname=tlf-git
_pkgname=tlf
-pkgver=1.3.0.r1.g3535aa1
+_author=Tlf
+pkgver=1.4.1.r245.g2b5c837
#.r1.g3535aa1
-pkgrel=1
-pkgdesc="a console mode networked logging and contest program for hamradio"
+pkgrel=2
+pkgdesc="Ham Radio networked logging and contest program - CLI"
arch=('i686' 'x86_64')
-url="https://tlf.github.com/"
+url="https://tlf.github.io/"
license=('GPL')
-depends=('hamlib' 'xmlrpc-c' 'hamradio-menus')
+depends=('xfce4-terminal' 'hamlib-git' 'xmlrpc-c' 'hamradio-menus')
makedepends=('autoconf' 'automake' 'pkg-config')
optdepends=('cwdaemon: transmitting cw'
+ 'winkeydaemon: transmitting cw'
'cty: country files'
'joe: editing qsos'
'xplanet: mapped qso display'
+ 'sox: audio signal handling'
'fldigi: digital modes/modem & gui/display')
provides=('tlf')
conflicts=('tlf')
-source=("$_pkgname::git+https://github.com/Tlf/tlf.git#branch=master"
-# http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/nrau
- $_pkgname.desktop
+source=("$_pkgname::git+https://github.com/$_author/$_pkgname.git#branch=master"
+ $_pkgname.desktop
$_pkgname.png
- $_pkgname.1)
+ $_pkgname.1)
pkgver() {
cd $_pkgname
@@ -34,7 +36,9 @@ build() {
cd $srcdir/$_pkgname
autoreconf --install
- ./configure --prefix=/usr --enable-hamlib --enable-fldigi-xmlrpc
+
+ CFLAGS=-Wno-error ./configure --prefix=/usr --enable-hamlib\
+ --enable-fldigi-xmlrpc
make || return 1
}
@@ -44,8 +48,6 @@ package() {
make prefix=$pkgdir/usr datadir=$pkgdir/usr/share install
-# cp ../nrau $pkgdir/usr/share/$pkgname
-
mkdir -p $pkgdir/usr/bin
mv $pkgdir/usr/bin/$_pkgname $pkgdir/usr/bin/$_pkgname.1
install -D -m 755 ../$_pkgname.1 $pkgdir/usr/bin/$_pkgname
@@ -55,10 +57,10 @@ package() {
install -D -m 644 ../$_pkgname.desktop $pkgdir/usr/share/applications
}
md5sums=('SKIP'
- 'b83cca73cea288ed139993efceb245b5'
+ 'ace42b89f5e7a686e4adc8b457f266f7'
'f148583e02660cb430f638fd8f71f452'
'b706428f41d32bd5f4f6f671057638c0')
sha256sums=('SKIP'
- 'cc7b5bcf825ea342d126a54a778c4f837ea0da4a12101383f99282041eb5d574'
+ 'babe8eeda21b9d55966ef74fcf7aa2eef50317b94576f271e5d5ff580f9f5327'
'0ddcde4f0dfa98540d4314660108ed49bfa0bc3d8b87cb46906dfd6f12be2497'
'766253a6f4b1d7e0526366875a46e220d637665c3c44e551f8d3db4ed88aaf81')
diff --git a/tlf.desktop b/tlf.desktop
index 24c156f23436..0831a7831cde 100644
--- a/tlf.desktop
+++ b/tlf.desktop
@@ -1,14 +1,7 @@
[Desktop Entry]
Name=TLF
-Name[en_US]=TLF
Comment=CT Style Logging Program
-Comment[en_US]=CT Style Logging Program
-Encoding=UTF-8
-Exec=xterm -geometry 80x25 -fn -*-fixed-medium-r-*-*-24-*-*-*-*-*-iso8859-* tlf
-Icon=tlf.png
-MimeType=text/plain
-StartupNotify=true
+Exec=xfce4-terminal --geometry 80x25 -x tlf
+Icon=tlf
Type=Application
-Categories=Application;HamRadio
-X-DCOP-ServiceType=none
-X-KDE-SubstituteUID=false
+Categories=Education;HamRadio