summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-02-02 22:08:27 +0100
committerHans-Nikolai Viessmann2020-02-02 22:08:27 +0100
commit4b437287ac3829bbb922dd008fad150f4c24b864 (patch)
tree07ef757662b3e31ec76551cc76f0b30ad809d25e
downloadaur-4b437287ac3829bbb922dd008fad150f4c24b864.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
-rw-r--r--tllocalmgr.patch58
3 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ad2b8617f0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = tllocalmgr-git
+ pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
+ pkgver = v0.7.r3.gbbd8488
+ pkgrel = 1
+ url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = texlive-core>=2011
+ depends = perl-libwww
+ depends = perl-term-shellui
+ depends = perl-term-readline-gnu
+ depends = perl-list-moreutils
+ depends = perl-lwp-protocol-https
+ provides = texlive-localmanager-git=v0.7.r3.gbbd8488
+ conflicts = texlive-localmanager
+ conflicts = texlive-localmanager-git
+ source = texlive-localmanager::git://git.archlinux.org/users/remy/texlive-localmanager.git
+ source = tllocalmgr.patch
+ sha256sums = SKIP
+ sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
+
+pkgname = tllocalmgr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3a377332c80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Hans-Nikolai Viessmann <hans at viess dot mn>
+# Contributor: XZS <d dot f dot fischer at web dot de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
+# Contributor: Firmicus <francois . archlinux . org>
+
+pkgname=tllocalmgr-git
+_pkgname='texlive-localmanager'
+pkgver=v0.7.r3.gbbd8488
+pkgrel=1
+pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
+arch=('any')
+url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
+license=('GPL')
+provides=("texlive-localmanager-git=$pkgver")
+conflicts=('texlive-localmanager'
+ 'texlive-localmanager-git')
+depends=('texlive-core>=2011'
+ 'perl-libwww'
+ 'perl-term-shellui'
+ 'perl-term-readline-gnu'
+ 'perl-list-moreutils'
+ 'perl-lwp-protocol-https')
+makedepends=('git')
+
+source=("${_pkgname}::git://git.archlinux.org/users/remy/texlive-localmanager.git"
+ 'tllocalmgr.patch')
+sha256sums=('SKIP'
+ '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_pkgname
+
+ # enhances the tllocalmgr script a bit
+ # thanks: @sharethewisdom and @cobaltspace
+ patch -p1 < "$srcdir/tllocalmgr.patch"
+}
+
+package() {
+ cd $_pkgname
+ install -d $pkgdir/usr/{bin,share/texmf/arch/tlpkg/TeXLive}
+ install -m755 tllocalmgr $pkgdir/usr/bin/
+ cd tlpkg/TeXLive
+ for _f in *; do
+ install -m644 $_f $pkgdir/usr/share/texmf/arch/tlpkg/TeXLive/
+ done
+}
diff --git a/tllocalmgr.patch b/tllocalmgr.patch
new file mode 100644
index 000000000000..a949ea909313
--- /dev/null
+++ b/tllocalmgr.patch
@@ -0,0 +1,58 @@
+diff --git a/tllocalmgr b/tllocalmgr
+index b947ed2..e238263 100755
+--- a/tllocalmgr
++++ b/tllocalmgr
+@@ -227,6 +227,7 @@ my @updatedpkgs; # pkgs for which updates are available
+ foreach my $col (sort keys %installedcol_versions) {
+ #my $installedver = `pacman -Q texlive-$col`;
+ #$installedver =~ s/texlive-$col $YEAR\.([0-9]+)-.+/$1/;
++ next if ( $col eq "tlpdb" ) ;
+ next unless ( $installedcol_versions{$col} < $versions{$col} ) ;
+ foreach my $pkg (sort @{$tlpackages{$col}}) {
+ my $tlpkg = $tlpdb->get_package($pkg);
+@@ -636,6 +637,7 @@ pkgrel=1
+ pkgdesc="TeX Live - local installation of CTAN package $pkg"
+ license=('GPL')
+ arch=('any')
++groups=('texlive-local')
+ depends=('texlive-core')
+ conflicts=('texlive-$col>=$YEAR.$newver')
+ url='http://tug.org/texlive/'
+@@ -670,11 +672,12 @@ EOF
+ # open INSTALL, "> $ROOT/builds/$pkg/texlive.install";
+ # print INSTALL $TLINSTALL;
+ # close INSTALL;
+- print LOG "* Running makepkg -ci on $ROOT/builds/$pkg/PKGBUILD\n";
++ system( "makepkg --printsrcinfo > .SRCINFO" );
++ print LOG "* Running makepkg -i on $ROOT/builds/$pkg/PKGBUILD\n";
+ chdir "$ROOT/builds/$pkg";
+ system( "test -f $pkg.tar.xz && rm $pkg.tar.xz" );
+ # TODO : catch error if makepkg fails
+- system( "makepkg -ci" );
++ system( "makepkg -i" );
+ }
+
+ print "\n>>> Finished. Don't forget to run 'texhash' to update your file database.\n";
+@@ -729,6 +732,7 @@ pkgrel=1
+ pkgdesc="TeX Live - local installation of CTAN package $pkg (documentation and sources)"
+ license=('GPL')
+ arch=('any')
++groups=('texlive-local')
+ depends=('texlive-core')
+ url='http://tug.org/texlive/'
+ EOF
+@@ -773,11 +777,12 @@ EOF
+ # open INSTALL, "> $ROOT/builds/$pkg/texlive.install";
+ # print INSTALL $TLINSTALL;
+ # close INSTALL;
+- print LOG "* Running makepkg -ci on $ROOT/builds/$pkg-doc/PKGBUILD\n";
++ system( "makepkg --printsrcinfo > .SRCINFO" );
++ print LOG "* Running makepkg -i on $ROOT/builds/$pkg-doc/PKGBUILD\n";
+ chdir "$ROOT/builds/$pkg-doc";
+ system( "test -f $pkg-*.tar.xz && rm $pkg-*.tar.xz" );
+ # TODO : catch error if makepkg fails
+- system( "makepkg -ci" );
++ system( "makepkg -i" );
+ }
+
+