summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-02-05 23:35:49 +0100
committerHans-Nikolai Viessmann2020-02-05 23:35:49 +0100
commit7cdbe92402c3297908a3c3d0351ea1c14118829a (patch)
treee307fa5b9278ccdb9d43c60237fc7c4f22b49ed2
parent4b437287ac3829bbb922dd008fad150f4c24b864 (diff)
downloadaur-7cdbe92402c3297908a3c3d0351ea1c14118829a.tar.gz
fix missing exclusion on pacman package listing
there is an assumption within the tllocalmgr script that the package name is of form 'texlive-local', which is used to filter out the list of tex packages so that we know which system (from archlinux repo) tex packages are actually installed. With this new package name, 'tllocalmgr-git', this is not excluded leading to a startup error.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--tllocalmgr-enhance.patch (renamed from tllocalmgr.patch)0
-rw-r--r--tllocalmgr-fix-texlive-local-match.patch13
4 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ad2b8617f0c..abfa483257d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tllocalmgr-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
pkgver = v0.7.r3.gbbd8488
- pkgrel = 1
+ pkgrel = 2
url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
arch = any
license = GPL
@@ -16,9 +16,11 @@ pkgbase = tllocalmgr-git
conflicts = texlive-localmanager
conflicts = texlive-localmanager-git
source = texlive-localmanager::git://git.archlinux.org/users/remy/texlive-localmanager.git
- source = tllocalmgr.patch
+ source = tllocalmgr-enhance.patch
+ source = tllocalmgr-fix-texlive-local-match.patch
sha256sums = SKIP
sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
+ sha256sums = a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7
pkgname = tllocalmgr-git
diff --git a/PKGBUILD b/PKGBUILD
index d3a377332c80..b152d39c65a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=tllocalmgr-git
_pkgname='texlive-localmanager'
pkgver=v0.7.r3.gbbd8488
-pkgrel=1
+pkgrel=2
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
@@ -24,9 +24,11 @@ depends=('texlive-core>=2011'
makedepends=('git')
source=("${_pkgname}::git://git.archlinux.org/users/remy/texlive-localmanager.git"
- 'tllocalmgr.patch')
+ 'tllocalmgr-enhance.patch'
+ 'tllocalmgr-fix-texlive-local-match.patch')
sha256sums=('SKIP'
- '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236')
+ '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236'
+ 'a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7')
pkgver() {
cd $_pkgname
@@ -38,7 +40,11 @@ prepare() {
# enhances the tllocalmgr script a bit
# thanks: @sharethewisdom and @cobaltspace
- patch -p1 < "$srcdir/tllocalmgr.patch"
+ patch -p1 < "$srcdir/tllocalmgr-enhance.patch"
+
+ # fix missing exclusion of matches for texlive local packages
+ # thanks: @CaptainBern
+ patch -p1 < "$srcdir/tllocalmgr-fix-texlive-local-match.patch"
}
package() {
diff --git a/tllocalmgr.patch b/tllocalmgr-enhance.patch
index a949ea909313..a949ea909313 100644
--- a/tllocalmgr.patch
+++ b/tllocalmgr-enhance.patch
diff --git a/tllocalmgr-fix-texlive-local-match.patch b/tllocalmgr-fix-texlive-local-match.patch
new file mode 100644
index 000000000000..d6f707510ad4
--- /dev/null
+++ b/tllocalmgr-fix-texlive-local-match.patch
@@ -0,0 +1,13 @@
+diff --git a/tllocalmgr b/tllocalmgr
+index b947ed2..b8d75dc 100755
+--- a/tllocalmgr
++++ b/tllocalmgr
+@@ -140,7 +140,7 @@ chomp(my @pacman = `pacman -Qs ^texlive- | egrep ^local | cut -d'/' -f2`);
+ my @localpacman = grep { /^texlive-local-/ } @pacman;
+ # To have the standard collections we get rid of
+ # texlive-local-<pkg> and texlive-localmanager:
+-my @collpacman = grep { !/^texlive-local/ } @pacman;
++my @collpacman = grep { !/^(texlive-local|tllocalmgr)/ } @pacman;
+
+ if (@localpacman) {
+ foreach (@localpacman) {