summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChad Sharp2015-06-19 13:06:02 +0100
committerChad Sharp2015-06-19 13:06:02 +0100
commit372397f016d786ad43c7371109c15c40f06dc98d (patch)
treeda6e90170b367b767e825114bf112e69283fea49
downloadaur-372397f016d786ad43c7371109c15c40f06dc98d.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71861f5d6a49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tlocate
+ pkgdesc = mlocate rewritten using only GNU coreutils, sudo and bash with proper btrfs subvolume handling, semi-arbitrary filtering and other improvements
+ pkgver = r4.4bcb781
+ pkgrel = 1
+ url = https://github.com/crossroads1112/tlocate
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/crossroads1112/tlocate.git
+ md5sums = SKIP
+
+pkgname = tlocate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2db075e222ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Chad "crossroads1112" Sharp <crossroads1112@riseup.net>
+pkgname=tlocate
+pkgver=r4.4bcb781
+pkgrel=1
+pkgdesc="mlocate rewritten using only GNU coreutils, sudo and bash with proper btrfs subvolume handling, semi-arbitrary filtering and other improvements"
+arch=('any')
+url="https://github.com/crossroads1112/tlocate"
+license=('GPL')
+depends=()
+makedepends=('git')
+source=(git+https://github.com/crossroads1112/tlocate.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "tlocate"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/tlocate"
+ install -Dm0755 tlocate "$pkgdir/usr/bin/tlocate"
+ install -Dm0644 tlocate.conf "$pkgdir/etc/tlocate.conf"
+}