summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSammysHP2022-06-16 19:18:55 +0200
committerSammysHP2022-06-16 19:18:55 +0200
commitd38a219c8c31ceafa020065917cf7a1165e8b533 (patch)
treec500c4335ed484bb4daf05a8a6f2f5b0f72f0828
parent6b407dae5b5872105837b67a3826e9ee169158b5 (diff)
downloadaur-d38a219c8c31ceafa020065917cf7a1165e8b533.tar.gz
Update to latest git version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--tlp.install9
3 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5901fe4ca0f8..dbadf251a719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = tlp-git
- pkgver = 1.3.1.r184.dc41e02
+ pkgver = 1.5.0.r10.135756d
pkgrel = 1
url = https://linrunner.de/en/tlp/tlp.html
+ install = tlp.install
arch = any
license = GPL2
makedepends = git
@@ -13,6 +14,7 @@ pkgname = tlp-git
depends = hdparm
depends = iw
depends = pciutils
+ depends = perl
depends = rfkill
depends = usbutils
depends = util-linux
@@ -21,12 +23,12 @@ pkgname = tlp-git
optdepends = ethtool: Disable Wake On Lan
optdepends = smartmontools: Display S.M.A.R.T. data in tlp-stat
optdepends = tp_smapi: ThinkPad battery functions
- optdepends = x86_energy_perf_policy: Set energy versus performance policy on x86 processors
provides = tlp
conflicts = laptop-mode-tools
conflicts = pm-utils
+ conflicts = power-profiles-daemon
conflicts = tlp
- backup = etc/default/tlp
+ backup = etc/tlp.conf
pkgname = tlp-rdw-git
pkgdesc = Linux Advanced Power Management - Radio Device Wizard
@@ -34,4 +36,3 @@ pkgname = tlp-rdw-git
depends = tlp
provides = tlp-rdw
conflicts = tlp-rdw
-
diff --git a/PKGBUILD b/PKGBUILD
index ca845222297c..b935e083b62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Sven Karsten Greiner <sven@sammyshp.de>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Marc Schulte <bomba@nerdstube.de>
pkgbase=tlp-git
@@ -6,7 +7,7 @@ pkgname=(
tlp-git
tlp-rdw-git
)
-pkgver=1.3.1.r184.dc41e02
+pkgver=1.5.0.r10.135756d
pkgrel=1
arch=(any)
url=https://linrunner.de/en/tlp/tlp.html
@@ -14,6 +15,7 @@ license=(GPL2)
makedepends=(git)
source=(git+https://github.com/linrunner/TLP.git)
sha256sums=(SKIP)
+install=tlp.install
pkgver() {
cd TLP
@@ -27,6 +29,7 @@ package_tlp-git() {
hdparm
iw
pciutils
+ perl
rfkill
usbutils
util-linux
@@ -37,15 +40,15 @@ package_tlp-git() {
'ethtool: Disable Wake On Lan'
'smartmontools: Display S.M.A.R.T. data in tlp-stat'
'tp_smapi: ThinkPad battery functions'
- 'x86_energy_perf_policy: Set energy versus performance policy on x86 processors'
)
provides=(tlp)
conflicts=(
laptop-mode-tools
pm-utils
+ power-profiles-daemon
tlp
)
- backup=(etc/default/tlp)
+ backup=(etc/tlp.conf)
export TLP_NO_INIT=1
export TLP_SBIN=/usr/bin
diff --git a/tlp.install b/tlp.install
new file mode 100644
index 000000000000..65353c41d694
--- /dev/null
+++ b/tlp.install
@@ -0,0 +1,9 @@
+post_upgrade() {
+ if [ $(vercmp $2 1.3.0) -lt 0 ]; then
+ cat << EOF
+The default TLP configuration has moved from /etc/default/tlp to /etc/tlp.conf.
+The syntax is the same, you can move your old configuration or start fresh.
+EOF
+ fi
+}
+