summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaditya Bagga2015-10-02 10:26:04 +0530
committerAaditya Bagga2015-10-02 10:26:04 +0530
commit215802eb0034dd139eb9d00168403696ff1f0a9d (patch)
tree5bb9464f28dff2bfa90e9b6f69e43cc53fd38dba
parentb57cf4cb56be7d1bfbdd9a79156c37a83f78c7dc (diff)
downloadaur-215802eb0034dd139eb9d00168403696ff1f0a9d.tar.gz
added tlp openrc service
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27a0d4b0a4a4..35e645e01d7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tlp-pmu
pkgdesc = Advanced Power Management for Linux, with pm-utils support
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html
install = tlp-pmu.install
arch = any
@@ -20,14 +20,17 @@ pkgbase = tlp-pmu
optdepends = smartmontools: Display S.M.A.R.T. data in tlp-stat
optdepends = tp_smapi: ThinkPad battery functions
optdepends = x86_energy_perf_policy: Set energy versus performance policy on x86 processors
+ optdepends = openrc-core: for using openrc tlp service
provides = tlp
conflicts = laptop-mode-tools
conflicts = tlp
backup = etc/default/tlp
source = https://github.com/linrunner/TLP/archive/0.8.tar.gz
source = tlp-arch.patch
+ source = https://github.com/dywisor/tlp-portage/raw/maint/app-laptop/tlp/files/tlp-init.openrc-r2
sha256sums = d5c0423fde7247cc519001caebd60e538ff5ef2be9456d2049303eef4da1aae3
sha256sums = d62af086a8c97db354c2bb57d21f4a2b4faa8e60335d5994fad07698e67b4eba
+ sha256sums = dd2a5bade0e904d685a6a8d0313cda6455820dd3bf634b424dac6ebb7c8334ff
pkgname = tlp-pmu
diff --git a/PKGBUILD b/PKGBUILD
index 71b52d037631..df2b24509fca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=('tlp-pmu')
_pkgname=tlp
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc='Advanced Power Management for Linux, with pm-utils support'
depends=('hdparm' 'iw' 'pciutils' 'rfkill' 'usbutils' 'util-linux' 'pm-utils')
optdepends=('acpi_call: Sandy Bridge and newer ThinkPad battery functions'
@@ -14,7 +14,8 @@ optdepends=('acpi_call: Sandy Bridge and newer ThinkPad battery functions'
'lsb-release: Display LSB release version in tlp-stat'
'smartmontools: Display S.M.A.R.T. data in tlp-stat'
'tp_smapi: ThinkPad battery functions'
- 'x86_energy_perf_policy: Set energy versus performance policy on x86 processors')
+ 'x86_energy_perf_policy: Set energy versus performance policy on x86 processors'
+ 'openrc-core: for using openrc tlp service')
conflicts=('laptop-mode-tools' 'tlp')
provides=($_pkgname)
backup=('etc/default/tlp')
@@ -23,9 +24,11 @@ arch=('any')
url='http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html'
license=('GPL2' 'GPL3')
source=("https://github.com/linrunner/TLP/archive/${pkgver}.tar.gz"
- 'tlp-arch.patch')
+ 'tlp-arch.patch'
+ 'https://github.com/dywisor/tlp-portage/raw/maint/app-laptop/tlp/files/tlp-init.openrc-r2')
sha256sums=('d5c0423fde7247cc519001caebd60e538ff5ef2be9456d2049303eef4da1aae3'
- 'd62af086a8c97db354c2bb57d21f4a2b4faa8e60335d5994fad07698e67b4eba')
+ 'd62af086a8c97db354c2bb57d21f4a2b4faa8e60335d5994fad07698e67b4eba'
+ 'dd2a5bade0e904d685a6a8d0313cda6455820dd3bf634b424dac6ebb7c8334ff')
prepare() {
cd TLP-${pkgver}
@@ -48,6 +51,10 @@ package() {
install -dm 755 "${pkgdir}"/usr/share/man/man{1,8}
install -m 644 man/*.1 "${pkgdir}"/usr/share/man/man1/
install -m 644 man/*.8 "${pkgdir}"/usr/share/man/man8/
+
+ # Move out tlp sysvinit service and replace it with the openrc one
+ mv "${pkgdir}/etc/init.d/tlp" "${pkgdir}/etc/init.d/tlp.sysvinit"
+ install -m 755 "${srcdir}/tlp-init.openrc-r2" "${pkgdir}/etc/init.d/tlp"
}
# vim: ts=2 sw=2 et: