summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaditya Bagga2016-09-04 12:22:31 +0530
committerAaditya Bagga2016-09-04 12:22:31 +0530
commit29d67f6d95e9d109a41677dfe1dfcffa7c553eab (patch)
tree68fd3b6397c96e16aa760a88cd202172f4a2d866
parent9f479e0b4553e9c93c64aeb81f9a114ae3e241ce (diff)
downloadaur-29d67f6d95e9d109a41677dfe1dfcffa7c553eab.tar.gz
Updated to version 0.9
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a39a29d8b6a2..4d51ceb2e99e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 29 21:58:51 UTC 2016
+# Sun Sep 4 06:50:26 UTC 2016
pkgbase = tlp-pmu
pkgdesc = Advanced Power Management for Linux, with pm-utils support
- pkgver = 0.8
- pkgrel = 3
+ pkgver = 0.9
+ pkgrel = 1
url = http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html
install = tlp-pmu.install
arch = any
@@ -16,21 +16,21 @@ pkgbase = tlp-pmu
depends = usbutils
depends = util-linux
depends = pm-utils
- optdepends = acpi_call: Sandy Bridge and newer ThinkPad battery functions
+ optdepends = acpi_call: ThinkPad battery functions, Sandy Bridge and newer
+ optdepends = bash-completion: Bash completion
optdepends = ethtool: Disable Wake On Lan
optdepends = lsb-release: Display LSB release version in tlp-stat
optdepends = smartmontools: Display S.M.A.R.T. data in tlp-stat
optdepends = tp_smapi: ThinkPad battery functions
optdepends = x86_energy_perf_policy: Set energy versus performance policy on x86 processors
+ optdepends = openrc: for using openrc tlp service
provides = tlp
conflicts = laptop-mode-tools
conflicts = tlp
backup = etc/default/tlp
- source = https://github.com/linrunner/TLP/archive/0.8.tar.gz
- source = tlp-arch.patch
+ source = https://github.com/linrunner/TLP/archive/0.9.tar.gz
source = https://github.com/dywisor/tlp-portage/raw/maint/app-laptop/tlp/files/tlp-init.openrc-r2
- sha256sums = d5c0423fde7247cc519001caebd60e538ff5ef2be9456d2049303eef4da1aae3
- sha256sums = d62af086a8c97db354c2bb57d21f4a2b4faa8e60335d5994fad07698e67b4eba
+ sha256sums = 887b226d443f930398fda5793ac690e1e1ef7dd2187db7be0278359315aa7a76
sha256sums = dd2a5bade0e904d685a6a8d0313cda6455820dd3bf634b424dac6ebb7c8334ff
pkgname = tlp-pmu
diff --git a/PKGBUILD b/PKGBUILD
index 6cb396ba7295..9680242552ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,12 @@
pkgname=('tlp-pmu')
_pkgname=tlp
-pkgver=0.8
-pkgrel=3
+pkgver=0.9
+pkgrel=1
pkgdesc='Advanced Power Management for Linux, with pm-utils support'
depends=('hdparm' 'iw' 'pciutils' 'rfkill' 'usbutils' 'util-linux' 'pm-utils')
-optdepends=('acpi_call: Sandy Bridge and newer ThinkPad battery functions'
+optdepends=('acpi_call: ThinkPad battery functions, Sandy Bridge and newer'
+ 'bash-completion: Bash completion'
'ethtool: Disable Wake On Lan'
'lsb-release: Display LSB release version in tlp-stat'
'smartmontools: Display S.M.A.R.T. data in tlp-stat'
@@ -25,16 +26,12 @@ arch=('any')
url='http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html'
license=('GPL2' 'GPL3')
source=("https://github.com/linrunner/TLP/archive/${pkgver}.tar.gz"
- 'tlp-arch.patch'
'https://github.com/dywisor/tlp-portage/raw/maint/app-laptop/tlp/files/tlp-init.openrc-r2')
-sha256sums=('d5c0423fde7247cc519001caebd60e538ff5ef2be9456d2049303eef4da1aae3'
- 'd62af086a8c97db354c2bb57d21f4a2b4faa8e60335d5994fad07698e67b4eba'
+sha256sums=('887b226d443f930398fda5793ac690e1e1ef7dd2187db7be0278359315aa7a76'
'dd2a5bade0e904d685a6a8d0313cda6455820dd3bf634b424dac6ebb7c8334ff')
prepare() {
- cd TLP-${pkgver}
-
- patch -Np1 -i ../tlp-arch.patch
+ sed -e 's/\/sbin\/openrc-run/\/usr\/bin\/openrc-run/' -e 's/\/usr\/sbin\/tlp/\/usr\/bin\/tlp/g' -i tlp-init.openrc-r2
}
package() {
@@ -47,11 +44,7 @@ package() {
export TLP_NO_PMUTILS='0'
export TLP_WITH_SYSTEMD='0'
- make DESTDIR="${pkgdir}" install-tlp
-
- install -dm 755 "${pkgdir}"/usr/share/man/man{1,8}
- install -m 644 man/*.1 "${pkgdir}"/usr/share/man/man1/
- install -m 644 man/*.8 "${pkgdir}"/usr/share/man/man8/
+ make DESTDIR="${pkgdir}" install-tlp install-man
# Move out tlp sysvinit service and replace it with the openrc one
mv "${pkgdir}/etc/init.d/tlp" "${pkgdir}/etc/init.d/tlp.sysvinit"