summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2018-06-06 17:55:00 -0400
committerLeo P2018-06-06 17:55:00 -0400
commit14bff75bc2b3f165b7aca4ebda952e2bf388b5c1 (patch)
tree02459f27eb0c55729a9f76ea51c19eeb7d794f7e
parent9409a5315459188fd4313add6acb6de2e2190e1a (diff)
downloadaur-14bff75bc2b3f165b7aca4ebda952e2bf388b5c1.tar.gz
add python-gobject dependency, remove __pycache__ stuff
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 067ce07e29b4..bc26355d0a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: slact
#author: Daniel Christophis
pkgname=tlpui-git
-pkgver=0.r84.ca97f57
-pkgrel=1
+pkgver=0.r88.ab1183a
+pkgrel=2
epoch=
pkgdesc="A GTK-UI to change TLP configuration files easily. It has the aim to protect users from setting bad configuration and to deliver a basic overview of all the valid configuration values."
arch=('any')
url="https://github.com/d4nj1/TLPUI"
license=('GPLv2')
groups=()
-depends=(tlp python pygtk)
+depends=("tlp" "python" "pygtk" "python-gobject")
makedepends=()
provides=()
conflicts=()
@@ -30,9 +30,13 @@ package() {
cd "$srcdir/TLPUI"
mkdir -p "$pkgdir"/opt/tlpui
cp -dpr --no-preserve=ownership ./ "$pkgdir"/opt/tlpui/
-
+ rm -Rf "$pkgdir"/opt/tlpui/tlpui/__pycache__
+ rm -Rf "$pkgdir"/opt/tlpui/tlpui/ui_config_objects/__pycache__
+
install -Dm644 "$srcdir"/tlpui.desktop "$pkgdir"/usr/share/applications/tlpui.desktop
install -Dm755 "$srcdir"/tlpui.sh "$pkgdir"/usr/bin/tlpui
+
+
}
# vim:set ts=2 sw=2 et: