summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2018-05-13 19:54:33 -0400
committerLeo P2018-05-13 19:54:33 -0400
commit9409a5315459188fd4313add6acb6de2e2190e1a (patch)
tree71d14d428c3a1c65259b89e72ea32115a94cd1dc
downloadaur-9409a5315459188fd4313add6acb6de2e2190e1a.tar.gz
first
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--tlpui.desktop9
-rw-r--r--tlpui.sh3
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd52294995e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun May 13 23:53:51 UTC 2018
+pkgbase = tlpui-git
+ pkgdesc = A GTK-UI to change TLP configuration files easily. It has the aim to protect users from setting bad configuration and to deliver a basic overview of all the valid configuration values.
+ pkgver = 0.r84.ca97f57
+ pkgrel = 1
+ url = https://github.com/d4nj1/TLPUI
+ arch = any
+ license = GPLv2
+ depends = tlp
+ depends = python
+ depends = pygtk
+ source = git+https://github.com/d4nj1/TLPUI.git
+ source = tlpui.sh
+ source = tlpui.desktop
+ md5sums = SKIP
+ md5sums = 9f23dcf973bac1089280be1255dfe34d
+ md5sums = ac5c088895666e9cdf095023acea5163
+
+pkgname = tlpui-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0eb1dc462c5d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+TLPUI
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..067ce07e29b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: slact
+#author: Daniel Christophis
+pkgname=tlpui-git
+pkgver=0.r84.ca97f57
+pkgrel=1
+epoch=
+pkgdesc="A GTK-UI to change TLP configuration files easily. It has the aim to protect users from setting bad configuration and to deliver a basic overview of all the valid configuration values."
+arch=('any')
+url="https://github.com/d4nj1/TLPUI"
+license=('GPLv2')
+groups=()
+depends=(tlp python pygtk)
+makedepends=()
+provides=()
+conflicts=()
+install=
+source=(git+https://github.com/d4nj1/TLPUI.git
+ tlpui.sh
+ tlpui.desktop)
+md5sums=('SKIP'
+ '9f23dcf973bac1089280be1255dfe34d'
+ 'ac5c088895666e9cdf095023acea5163')
+
+pkgver() {
+ cd "TLPUI"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/TLPUI"
+ mkdir -p "$pkgdir"/opt/tlpui
+ cp -dpr --no-preserve=ownership ./ "$pkgdir"/opt/tlpui/
+
+ install -Dm644 "$srcdir"/tlpui.desktop "$pkgdir"/usr/share/applications/tlpui.desktop
+ install -Dm755 "$srcdir"/tlpui.sh "$pkgdir"/usr/bin/tlpui
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/tlpui.desktop b/tlpui.desktop
new file mode 100644
index 000000000000..175adf2c7426
--- /dev/null
+++ b/tlpui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=TLPUI
+Comment=A GTK user interface for TLP
+Keywords=TLP TLP-UI
+Exec=tlpui
+Terminal=false
+Type=Application
+Categories=Settings;HardwareSettings
diff --git a/tlpui.sh b/tlpui.sh
new file mode 100644
index 000000000000..615f6f93d612
--- /dev/null
+++ b/tlpui.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/tlpui
+python3 -m tlpui