summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-01-18 07:47:02 -0600
committerHurricanePootis2024-01-18 07:47:02 -0600
commitfa58e9613060a18145624272d2b0ff82aa8f6eea (patch)
treea746bd8d68fd426bb2b29c9681532ba6cb6338a7
parentf382f171e7612162c9f691cc57302b3e358fa599 (diff)
downloadaur-fa58e9613060a18145624272d2b0ff82aa8f6eea.tar.gz
Update to 1.7.0 and update depends and makedepends
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c99be189b30..f2eed8eeb14d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tlpui
pkgdesc = A GTK user interface for TLP written in Python
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
epoch = 1
url = https://github.com/d4nj1/TLPUI
@@ -10,9 +10,14 @@ pkgbase = tlpui
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-poetry
depends = tlp
depends = python-gobject
- source = https://github.com/d4nj1/TLPUI/archive/refs/tags/tlpui-1.6.1.tar.gz
- sha256sums = 7889e08b52d93a3a96692b5fe0564e3d6da0a721072a673c0981fd3670c0d2fe
+ depends = hicolor-icon-theme
+ depends = python-yaml
+ depends = gtk3
+ depends = python-toml
+ source = https://github.com/d4nj1/TLPUI/archive/refs/tags/tlpui-1.7.0.tar.gz
+ sha256sums = d4fd41053e28ffff2aaffa14c47d2c41a6a2f4e3c425d9e26357d164f27717ca
pkgname = tlpui
diff --git a/PKGBUILD b/PKGBUILD
index 02fc862d04f2..baba64ec7846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
# Contributor: slact
pkgname=tlpui
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=1
epoch=1
pkgdesc="A GTK user interface for TLP written in Python"
arch=('any')
url="https://github.com/d4nj1/TLPUI"
license=('GPL2')
-depends=('tlp' 'python-gobject')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+depends=('tlp' 'python-gobject' 'hicolor-icon-theme' 'python-yaml' 'gtk3' 'python-toml')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'python-poetry')
source=("https://github.com/d4nj1/TLPUI/archive/refs/tags/$pkgname-$pkgver.tar.gz")
-sha256sums=('7889e08b52d93a3a96692b5fe0564e3d6da0a721072a673c0981fd3670c0d2fe')
+sha256sums=('d4fd41053e28ffff2aaffa14c47d2c41a6a2f4e3c425d9e26357d164f27717ca')
build() {
cd "TLPUI-$pkgname-$pkgver"