summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2016-03-14 19:42:10 -0700
committermutantmonkey2016-03-14 19:42:10 -0700
commitf51eb5fb7246fd897ce3ff2177a556f03241039d (patch)
treeb1a8c1dd5479c742177fe920fa8256f802061cb2
parent527b12456eaac3832fd318899a79c74c51a8056d (diff)
downloadaur-f51eb5fb7246fd897ce3ff2177a556f03241039d.tar.gz
upgpkg: tlsdate-git 707.ae396da-2
add no_sslv3.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--no_sslv3.patch65
3 files changed, 76 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cee701850639..cacc52a958b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Mar 15 02:42:10 UTC 2016
pkgbase = tlsdate-git
pkgdesc = A secure rdate replacement to update local time over HTTPS, git version
pkgver = 707.ae396da
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ioerror/tlsdate
install = tlsdate.install
arch = i686
@@ -25,9 +27,11 @@ pkgbase = tlsdate-git
source = git+https://github.com/ioerror/tlsdate.git
source = tlsdate.conf.d
source = tlsdate.service
+ source = no_sslv3.patch
sha256sums = SKIP
sha256sums = 1498a74913feb66c6e2e7d982f43b07fc48881947543969668a75ef4323503aa
sha256sums = fe3fb8181be0a9214f351c64461680f603ea27b7b7c566c9eec189084783aa92
+ sha256sums = 897661cd7a131e3b28678ffeb32477d44cccea7a4e069f9cbd27a1d17563a427
pkgname = tlsdate-git
diff --git a/PKGBUILD b/PKGBUILD
index d220df27b7fe..5b3c20d575c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: skydrome <skydrome@tormail.org>
pkgname=tlsdate-git
pkgver=707.ae396da
-pkgrel=1
+pkgrel=2
pkgdesc="A secure rdate replacement to update local time over HTTPS, git version"
arch=('i686' 'x86_64' 'armv6l' 'armv6h' 'arm7l' 'arm7h')
url="https://github.com/ioerror/tlsdate"
@@ -16,10 +16,12 @@ backup=('etc/conf.d/tlsdate'
'etc/tlsdate/tlsdated.conf')
source=('git+https://github.com/ioerror/tlsdate.git'
'tlsdate.conf.d'
- 'tlsdate.service')
+ 'tlsdate.service'
+ 'no_sslv3.patch')
sha256sums=('SKIP'
'1498a74913feb66c6e2e7d982f43b07fc48881947543969668a75ef4323503aa'
- 'fe3fb8181be0a9214f351c64461680f603ea27b7b7c566c9eec189084783aa92')
+ 'fe3fb8181be0a9214f351c64461680f603ea27b7b7c566c9eec189084783aa92'
+ '897661cd7a131e3b28678ffeb32477d44cccea7a4e069f9cbd27a1d17563a427')
pkgver() {
cd "$srcdir/tlsdate"
@@ -28,6 +30,7 @@ pkgver() {
prepare() {
cd "$srcdir/tlsdate"
+ patch -N -p1 -i ../no_sslv3.patch
./autogen.sh
}
diff --git a/no_sslv3.patch b/no_sslv3.patch
new file mode 100644
index 000000000000..7d7cb0b690e8
--- /dev/null
+++ b/no_sslv3.patch
@@ -0,0 +1,65 @@
+diff --git a/man/tlsdate.1 b/man/tlsdate.1
+index b052e48..b2ea687 100644
+--- a/man/tlsdate.1
++++ b/man/tlsdate.1
+@@ -5,7 +5,7 @@
+ .SH NAME
+ tlsdate \- secure parasitic rdate replacement
+ .SH SYNOPSIS
+-.B tlsdate [\-hnvVstlw] [\-H [hostname]] [\-p [port]] [\-P [sslv23|sslv3|tlsv1]] \
++.B tlsdate [\-hnvVstlw] [\-H [hostname]] [\-p [port]] [\-P [sslv23|tlsv1]] \
+ [\-\-certdir [dirname]] [\-x [\-\-proxy] proxy\-type://proxyhost:proxyport]
+ .SH DESCRIPTION
+ .B tlsdate
+@@ -30,7 +30,7 @@ Set remote hostname (default: 'google.com')
+ Do not set the system clock to the time of the remote server
+ .IP "\-p | \-\-port [port]"
+ Set remote port (default: '443')
+-.IP "\-P | \-\-protocol [sslv23|sslv3|tlsv1]"
++.IP "\-P | \-\-protocol [sslv23|tlsv1]"
+ Set protocol to use when communicating with server (default: 'tlsv1')
+ .IP "\-C | \-\-certdir [dirname]"
+ Set the local directory where certificates are located
+diff --git a/src/tlsdate-helper-plan9.c b/src/tlsdate-helper-plan9.c
+index 3c532aa..bd79cf5 100644
+--- a/src/tlsdate-helper-plan9.c
++++ b/src/tlsdate-helper-plan9.c
+@@ -978,10 +978,6 @@ run_ssl (uint32_t *time_map, int time_is_an_illusion)
+ {
+ verb ("V: using SSLv23_client_method()\n");
+ ctx = SSL_CTX_new(SSLv23_client_method());
+- } else if (0 == strcmp("sslv3", protocol))
+- {
+- verb ("V: using SSLv3_client_method()\n");
+- ctx = SSL_CTX_new(SSLv3_client_method());
+ } else if (0 == strcmp("tlsv1", protocol))
+ {
+ verb ("V: using TLSv1_client_method()\n");
+diff --git a/src/tlsdate-helper.c b/src/tlsdate-helper.c
+index 877c67e..ba115e7 100644
+--- a/src/tlsdate-helper.c
++++ b/src/tlsdate-helper.c
+@@ -1133,10 +1133,6 @@ run_ssl (uint32_t *time_map, int time_is_an_illusion, int http)
+ {
+ verb ("V: using SSLv23_client_method()");
+ ctx = SSL_CTX_new(SSLv23_client_method());
+- } else if (0 == strcmp("sslv3", protocol))
+- {
+- verb ("V: using SSLv3_client_method()");
+- ctx = SSL_CTX_new(SSLv3_client_method());
+ } else if (0 == strcmp("tlsv1", protocol))
+ {
+ verb ("V: using TLSv1_client_method()");
+diff --git a/src/tlsdate.c b/src/tlsdate.c
+index dd7f993..b4404d7 100644
+--- a/src/tlsdate.c
++++ b/src/tlsdate.c
+@@ -88,7 +88,7 @@ usage (void)
+ " [-n|--dont-set-clock]\n"
+ " [-H|--host] [hostname|ip]\n"
+ " [-p|--port] [port number]\n"
+- " [-P|--protocol] [sslv23|sslv3|tlsv1]\n"
++ " [-P|--protocol] [sslv23|tlsv1]\n"
+ " [-C|--certcontainer] [dirname|filename]\n"
+ " [-v|--verbose]\n"
+ " [-V|--showtime] [human|raw]\n"