summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-03-23 15:31:09 +0100
committera8212024-03-23 15:31:09 +0100
commitbc69f5effc9610ec5f936d14512367a47f930b19 (patch)
treedb6ccb5bae0a6f58259c456413a9692e018909bb
parentd0526bd7a72d08c6ce41366b3c56a481386fc880 (diff)
downloadaur-bc69f5effc9610ec5f936d14512367a47f930b19.tar.gz
Update PKGBUILD. Sync with official package
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 45 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2d58fdf0573..d92d81c0c60c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = tmate-git
- pkgdesc = Instant Terminal Sharing http://tmate.io/
- pkgver = 2.2.0
+ pkgdesc = Instant terminal sharing
+ pkgver = 2.4.0.r29.gac919516
pkgrel = 1
- url = http://tmate.io/
- arch = i686
+ url = https://tmate.io/
arch = x86_64
- license = MIT
- makedepends = cmake
- makedepends = libevent
- makedepends = ncurses
- makedepends = openssl
- makedepends = zlib
- makedepends = ruby
- makedepends = msgpack-c
+ license = ISC
+ makedepends = git
+ depends = libevent
+ depends = libssh
+ depends = libutempter
+ depends = msgpack-c
+ depends = ncurses
+ source = git+https://github.com/tmate-io/tmate.git
+ sha256sums = SKIP
pkgname = tmate-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8196c74d9b2b..5bc4d77f8e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,40 @@
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: "Amhairghin" Oscar Garcia Amor
+# Contributors: bhushan, huma, adlaiff6, Invie, solarce
+
pkgname=tmate-git
-pkgver=2.2.0
+pkgver=2.4.0.r29.gac919516
pkgrel=1
-pkgdesc="Instant Terminal Sharing http://tmate.io/"
-arch=('i686' 'x86_64')
-license=('MIT')
-url="http://tmate.io/"
-makedepends=('cmake' 'libevent' 'ncurses' 'openssl' 'zlib' 'ruby' 'msgpack-c')
+pkgdesc="Instant terminal sharing"
+arch=('x86_64')
+url="https://tmate.io/"
+license=('ISC')
+depends=('libevent' 'libssh' 'libutempter' 'msgpack-c' 'ncurses')
+makedepends=('git')
+source=("git+https://github.com/tmate-io/tmate.git")
+sha256sums=('SKIP')
-gitroot="https://github.com/tmate-io/tmate.git"
-gitname="tmate"
-gitbranch="2.2.0"
+pkgver() {
+ cd tmate
+ git describe --tags | sed 's/-/.r/;s/-/./g'
+}
-build() {
- cd ${srcdir}
- if [[ -d ${gitname} ]] ; then
- cd ${gitname}
- else
- git clone -b ${gitbranch} --depth=1 ${gitroot}
- cd ${gitname}
- fi
+prepare() {
+ cd tmate
./autogen.sh
+ autoupdate
+}
+
+build() {
+ cd tmate
./configure --prefix=/usr
make
}
package() {
- cd ${gitname}
- make DESTDIR=${pkgdir} install
+ cd tmate
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/$pkgname" COPYING
}
+
+# vim: set ts=2 sw=2 et: