summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben Agin2023-04-29 06:12:09 -0500
committerRuben Agin2023-04-29 06:12:09 -0500
commit334b79b2da3822b7edaee69766b2e34992a1aa9b (patch)
treea3f8cf04ae7efb99fd336698761cc3be78e0af62
parentbdeaeab1ad0f4308c20288ca585ce746a3ce3ea2 (diff)
downloadaur-334b79b2da3822b7edaee69766b2e34992a1aa9b.tar.gz
Update to latest version.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
-rw-r--r--tme.install1
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8072d58922d..9a8093e8b7a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = tme
pkgdesc = The Machine Emulator, or tme, provides a general-purpose framework for computer emulation.
- pkgver = 0.10
+ pkgver = 0.12rc10
pkgrel = 1
url = http://phabrics.com
install = tme.install
arch = i686
arch = x86_64
license = GPL3
- depends = libltdl
- depends = libnftnl
- depends = gtk3
- depends = libpcap
- source = http://phabrics.com/tme-0.10.tar.xz
- md5sums = a4cf29de03ee711a1aa0313117acb505
+ depends = libvncserver
+ depends = gtk4
+ depends = sdl2
+ options = libtool
+ source = https://osdn.net/dl/nme/tme-0.12rc10.tar.xz
+ sha256sums = e2c90f7c63de196c7bf52c9b06f17e2ab9db86fa86d8c3ff3ee2360fb20914f8
pkgname = tme
-
diff --git a/PKGBUILD b/PKGBUILD
index a4885055a301..0c4b02cff566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Ruben Agin <phabrics@phabrics.com>
pkgname=tme
-pkgver=0.10
+pkgver=0.12rc10
pkgrel=1
pkgdesc="The Machine Emulator, or tme, provides a general-purpose framework for computer emulation."
arch=('i686' 'x86_64')
license=('GPL3')
url="http://phabrics.com"
-makedepends=()
-depends=('libltdl' 'libnftnl' 'gtk3' 'libpcap')
-source=(http://phabrics.com/$pkgname-$pkgver.tar.xz)
+depends=('libvncserver' 'gtk4' 'sdl2')
+source=("https://osdn.net/dl/nme/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('e2c90f7c63de196c7bf52c9b06f17e2ab9db86fa86d8c3ff3ee2360fb20914f8')
+options=('libtool')
install=$pkgname.install
-md5sums=('a4cf29de03ee711a1aa0313117acb505')
build()
{
cd "$pkgname-$pkgver"
if test "x${CARCH}" = xx86_64; then
- ./configure --prefix=/usr --disable-recode
+ ./configure --prefix=/usr --disable-ltdl-install --disable-recode
else
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --disable-ltdl-install
fi
make
}
diff --git a/tme.install b/tme.install
index 7fb1d6a0b8a8..e6bef7f66b67 100644
--- a/tme.install
+++ b/tme.install
@@ -1,5 +1,6 @@
post_install() {
setcap cap_sys_nice,cap_net_admin,cap_net_raw+ep usr/bin/tmesh
+ chmod u-s usr/bin/tmesh
}
post_upgrade() {