diff options
author | Ruben Agin | 2023-04-30 04:06:18 -0500 |
---|---|---|
committer | Ruben Agin | 2023-04-30 04:06:18 -0500 |
commit | 5b58821b7c9371e47e7c6f5c65ce5e84c38280d6 (patch) | |
tree | ee619a1b8d36b6145d80fcc77d62a45052893901 | |
parent | 334b79b2da3822b7edaee69766b2e34992a1aa9b (diff) | |
download | aur-5b58821b7c9371e47e7c6f5c65ce5e84c38280d6.tar.gz |
Add an external declaration to _tme_scanline_pad in display.c to force non-inlined definition inside of it, per gcc documentation. This should fix NME ticket #47963 hopefully.
-rw-r--r-- | PKGBUILD | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -12,6 +12,12 @@ sha256sums=('e2c90f7c63de196c7bf52c9b06f17e2ab9db86fa86d8c3ff3ee2360fb20914f8') options=('libtool') install=$pkgname.install +prepare() +{ + cd "$pkgname-$pkgver" + sed -i '/#include "display.h"/i unsigned int _tme_scanline_pad(int bpl);' host/display/display.c +} + build() { cd "$pkgname-$pkgver" |