summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2021-12-17 15:31:32 +0100
committerDušan Simić2021-12-17 15:31:32 +0100
commit613f13bccea2cca250b613b67dcdfea72a885d27 (patch)
treec0a727684d9f24304d35f34a96094a8fde8264ff
downloadaur-613f13bccea2cca250b613b67dcdfea72a885d27.tar.gz
Add all files
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cab242ac078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmpmail
+ pkgdesc = A temporary email right from your terminal written in POSIX sh
+ pkgver = 1.1.9
+ pkgrel = 1
+ url = https://github.com/sdushantha/tmpmail
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = w3m
+ depends = curl
+ depends = jq
+ source = git+https://github.com/sdushantha/tmpmail.git#commit=0fdfe4955cfd0fff44a6c9073a4c30816e1cd615
+ md5sums = SKIP
+
+pkgname = tmpmail
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6925b0926590
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=tmpmail
+pkgver=1.1.9
+_commit=0fdfe4955cfd0fff44a6c9073a4c30816e1cd615
+pkgrel=1
+pkgdesc='A temporary email right from your terminal written in POSIX sh'
+arch=(any)
+url=https://github.com/sdushantha/tmpmail
+license=(MIT)
+depends=(w3m curl jq)
+makedepends=(git)
+source=("git+$url.git#commit=$_commit")
+md5sums=(SKIP)
+
+package() {
+ cd "$pkgname"
+ install -Dm755 tmpmail -t "$pkgdir/usr/bin"
+ install -Dm644 tmpmail.1 -t "$pkgdir/usr/share/man/man1"
+}