summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Böger2017-09-16 00:29:08 +0200
committerLukas Böger2017-09-16 00:29:08 +0200
commita83a7974b7f6c16e085fab18dfce489cfb4877f2 (patch)
tree0093f6855395c5501e620832705cc91c5897003a
downloadaur-a83a7974b7f6c16e085fab18dfce489cfb4877f2.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD44
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68a365c96dcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tmsu-git
+ pkgdesc = Tag your files and access them through a virtual filesystem
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = http://tmsu.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ conflicts = tmsu
+ source = git+https://github.com/oniony/tmsu.git
+ sha256sums = SKIP
+
+pkgname = tmsu-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..656aa7b94a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Lukas Böger <dev AT lboeger DOT de>
+# Contributor: Francesco Turco <fturco AT fastmail DOT fm>
+# Contributor: Marcin Wieczorek <marcin AT marcin DOT co>
+
+pkgname=tmsu-git
+pkgver=0.6.1
+pkgrel=1
+
+pkgdesc='Tag your files and access them through a virtual filesystem'
+arch=('i686' 'x86_64')
+url="http://tmsu.org/"
+license=('GPL3')
+
+makedepends=('git' 'go')
+conflicts=("${pkgname%-git}")
+
+source=("git+https://github.com/oniony/${pkgname/-/.}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+
+ printf '%s+g%s' $(git tag -l 'v*' | tail -n 1 | cut -c 2-) $(git describe --always)
+}
+
+build() {
+ export GOPATH=/tmp
+
+ go get -u github.com/mattn/go-sqlite3
+ go get -u github.com/hanwen/go-fuse/fuse
+
+ cd "${srcdir}/${pkgname%-git}"
+ make dist
+}
+
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ make install DESTDIR="${pkgdir}" MOUNT_INSTALL_DIR="${pkgdir}/usr/bin"
+}