summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-05-12 00:08:58 +0100
committerWorMzy Tykashi2024-05-12 00:08:58 +0100
commit24461c27a7de769d55a2fa740db2d62605788602 (patch)
treedd62f334f87eaa15314919d07efa071a6bbc7ec6
parentce036dfd7eb94edaf5b358b41f994503f5110223 (diff)
downloadaur-24461c27a7de769d55a2fa740db2d62605788602.tar.gz
Update licenses, expand optional depends
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD23
3 files changed, 18 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29cc4d425f89..2ae2dd7b6283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = tmux-git
pkgdesc = A terminal multiplexer
- pkgver = 10096_3.3a.r263.g62f65784
+ pkgver = 10201_3.4.r33.g3823fa2c
pkgrel = 1
url = https://github.com/tmux/tmux/wiki
arch = i686
arch = x86_64
arch = aarch64
- license = BSD
+ license = BSD-2-Clause
+ license = BSD-3-Clause
+ license = ISC
makedepends = git
+ depends = glibc
depends = ncurses
depends = libevent
- optdepends = libutempter: Record user sessions to utmp and wtmp files [add to depends array and rebuild to enable]
provides = tmux
conflicts = tmux
source = git+https://github.com/tmux/tmux.git
- source = LICENSE
md5sums = SKIP
- md5sums = 71601bc37fa44e4395580b321963018e
pkgname = tmux-git
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 3ccacc76d874..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,13 +0,0 @@
-Copyright (c) 2007 Nicholas Marriott <nicm@users.sourceforge.net>
-
-Permission to use, copy, modify, and distribute this software for any
-purpose with or without fee is hereby granted, provided that the above
-copyright notice and this permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-WHATSOEVER RESULTING FROM LOSS OF MIND, USE, DATA OR PROFITS, WHETHER
-IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
-OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 77b5f4350539..c4aeee78595c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,22 @@
pkgname=tmux-git
_gitname=tmux
-pkgver=10096_3.3a.r263.g62f65784
+pkgver=10201_3.4.r33.g3823fa2c
pkgrel=1
pkgdesc="A terminal multiplexer"
url="https://github.com/tmux/tmux/wiki"
arch=('i686' 'x86_64' 'aarch64')
-license=('BSD')
-depends=('ncurses' 'libevent')
+license=('BSD-2-Clause' 'BSD-3-Clause' 'ISC')
+depends=('glibc' 'ncurses' 'libevent')
makedepends=('git')
-optdepends=('libutempter: Record user sessions to utmp and wtmp files [add to depends array and rebuild to enable]')
-#depends+=('libutempter') && _addconfigureflags="--enable-utempter"
+#depends+=('libutempter') && _addconfigureflags+="--enable-utempter "
+#depends+=('libutf8proc') && _addconfigureflags+="--enable-utf8proc "
+#depends+=('systemd-libs') && _addconfigureflags+="--enable-systemd "
+#depends+=('libsixel') && _addconfigureflags+="--enable-sixel "
provides=('tmux')
conflicts=('tmux')
-source=('git+https://github.com/tmux/tmux.git'
- 'LICENSE')
-md5sums=('SKIP'
- '71601bc37fa44e4395580b321963018e')
+source=('git+https://github.com/tmux/tmux.git')
+md5sums=('SKIP')
pkgver() {
cd ${_gitname}
@@ -46,7 +46,10 @@ package() {
cd ${_gitname}
make DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ sed -n '2,14p' compat/daemon-darwin.c > "${pkgdir}/usr/share/licenses/${pkgname}/ISC-LICENSE"
+ sed -n '18,45p' compat/daemon-darwin.c > "${pkgdir}/usr/share/licenses/${pkgname}/BSD-2-Clause-LICENSE"
+ sed -n '5,33p' compat/bitstring.h > "${pkgdir}/usr/share/licenses/${pkgname}/BSD-3-Clause-LICENSE"
# install example config file
install -Dm755 example_tmux.conf "${pkgdir}/usr/share/tmux/example_tmux.conf"