summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-12 22:54:34 +0100
committerWorMzy Tykashi2015-06-12 22:54:34 +0100
commit5f1f793dafac087cf7fe6de852c3c8a0763300c6 (patch)
tree4329b95b1527464b101ea56df2359c27ae7574b6
downloadaur-5f1f793dafac087cf7fe6de852c3c8a0763300c6.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD54
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ac91752f2ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tmux-git
+ pkgdesc = A terminal multiplexer
+ pkgver = 2.0.r156.g83a7017
+ pkgrel = 1
+ url = http://tmux.github.io
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = ncurses
+ depends = libevent
+ optdepends = libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)
+ provides = tmux
+ conflicts = tmux
+ source = git+https://github.com/tmux/tmux.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 71601bc37fa44e4395580b321963018e
+
+pkgname = tmux-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3ccacc76d874
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+Copyright (c) 2007 Nicholas Marriott <nicm@users.sourceforge.net>
+
+Permission to use, copy, modify, and distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF MIND, USE, DATA OR PROFITS, WHETHER
+IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
+OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89837fa64df0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Dmitry Korzhevin <dkorzhevin AT gmail DOT com>
+# Contributor: C.Coutinho <kikijump[at]gmail[dot]com>
+# Contributor: Grigorios Bouzakis <grbzks[at]gmail[dot]com>
+# Contributor: TDY <tdy@gmx.com>
+
+pkgname=tmux-git
+_gitname=tmux
+pkgver=2.0.r156.g83a7017
+pkgrel=1
+pkgdesc="A terminal multiplexer"
+url="http://tmux.github.io"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('ncurses' 'libevent')
+makedepends=('git')
+optdepends=('libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)')
+#depends+=('libutempter')
+provides=('tmux')
+conflicts=('tmux')
+source=('git+https://github.com/tmux/tmux.git'
+ 'LICENSE')
+md5sums=('SKIP'
+ '71601bc37fa44e4395580b321963018e')
+
+pkgver() {
+ cd $_gitname
+ git describe --long | sed -e 's:\([^-]*-g\):r\1:' -e 's:-:.:g'
+}
+
+prepare() {
+ cd $_gitname
+ ./autogen.sh
+}
+
+build() {
+ cd $_gitname
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 examples/tmux.vim "$pkgdir/usr/share/vim/vimfiles/syntax/tmux.vim"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/tmux/LICENSE"
+ install -dm755 "$pkgdir/usr/share/tmux/"
+ install -m644 examples/* "$pkgdir/usr/share/tmux/"
+
+ # move bash_completion file
+ install -d "$pkgdir/usr/share/bash-completion/completions/"
+ mv "$pkgdir/usr/share/tmux/bash_completion_tmux.sh" "$pkgdir/usr/share/bash-completion/completions/tmux"
+}