summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:37:19 +0800
committerDaniel YC Lin2015-06-13 11:37:19 +0800
commitf6594cac06758301005680d0d0b771e68aab574d (patch)
tree8498b6c5a1b14dc2d40113798195012c0475a6ae
downloadaur-f6594cac06758301005680d0d0b771e68aab574d.tar.gz
merge to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bed58c564d9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tmux-mem-cpu-load-git
+ pkgdesc = CPU, RAM memory, and load monitor for use with tmux
+ pkgver = 2.2.1.r3.g660481f
+ pkgrel = 2
+ url = https://github.com/thewtex/tmux-mem-cpu-load
+ arch = i686
+ arch = x86_64
+ arch = sh4
+ license = APACHE
+ makedepends = cmake>=2.6
+ depends = gcc-libs
+ source = repo::git+https://github.com/thewtex/tmux-mem-cpu-load
+ md5sums = SKIP
+
+pkgname = tmux-mem-cpu-load-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05e7a6298f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4975b1f09623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+
+pkgname=tmux-mem-cpu-load-git
+pkgver=3.2.1.r4.g557528b
+pkgrel=1
+pkgdesc="CPU, RAM memory, and load monitor for use with tmux"
+url="https://github.com/thewtex/tmux-mem-cpu-load"
+arch=('i686' 'x86_64' 'sh4')
+license=('APACHE')
+depends=(gcc-libs)
+makedepends=('cmake>=2.6')
+source=('repo::git+https://github.com/thewtex/tmux-mem-cpu-load')
+md5sums=('SKIP')
+
+pkgver() {
+ cd repo
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+build() {
+ cd repo
+ cmake .
+ make
+}
+package() {
+ cd repo
+ install -Dm755 tmux-mem-cpu-load $pkgdir/usr/bin/tmux-mem-cpu-load
+}
+# vim:et sw=2 ts=2 ai