summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Rarick2021-06-25 17:09:32 -0500
committerTyler Rarick2021-06-25 17:09:32 -0500
commitb31d7f302adc870248a6e4e5d73c76a4afc5ea32 (patch)
tree98af2edf445a9bf92cc9738d4f631d2db4d37f4d
downloadaur-b31d7f302adc870248a6e4e5d73c76a4afc5ea32.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--tmux-plugin-manager.install28
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bbe9a893167
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmux-plugin-manager
+ pkgdesc = tpm - Tmux Plugin Manager
+ pkgver = v3.0.0.r60.g2afeff1
+ pkgrel = 1
+ url = https://github.com/tmux-plugins/tpm
+ install = tmux-plugin-manager.install
+ arch = any
+ license = MIT
+ depends = tmux>=1.9
+ depends = git
+ depends = bash
+ source = git+https://github.com/tmux-plugins/tpm.git#branch=master
+ sha256sums = SKIP
+
+pkgname = tmux-plugin-manager
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84d1bbd84df4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: rarick <tyler dot rarick at gmail dot com>
+
+pkgname=tmux-plugin-manager
+pkgver=v3.0.0.r60.g2afeff1
+pkgrel=1
+pkgdesc="tpm - Tmux Plugin Manager"
+arch=('any')
+_repo=tpm
+url="https://github.com/tmux-plugins/$_repo"
+license=('MIT')
+depends=('tmux>=1.9' 'git' 'bash')
+install=$pkgname.install
+source=("git+$url.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_repo
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ echo " -> Installing tpm..."
+ install -dDm 755 "$pkgdir/usr/share/$pkgname"
+ cp -r $_repo/* "$pkgdir/usr/share/$pkgname"
+}
diff --git a/tmux-plugin-manager.install b/tmux-plugin-manager.install
new file mode 100644
index 000000000000..6707533123d8
--- /dev/null
+++ b/tmux-plugin-manager.install
@@ -0,0 +1,28 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Add the following line to the end of your ~/.tmux.conf:"
+ echo
+ echo " run '/usr/share/tmux-plugin-manager/tpm'"
+ echo
+ note "If already running tmux, run the following to reload your current session:"
+ echo
+ echo " tmux source ~/.tmux.conf"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}